
 

 
 

1 
 

     
 

 

SCHOOL OF ELECTRICAL AND ELECTRONICS  

 

DEPARTMENT OF ELECTRICAL AND ELECTRONICS ENGINEERING 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 

                                  

 

 

 

 

UNIT – I – INTRODUCTION TO COMPUTER HARDWARE – SBS1104 



 

 
 

2 
 

      UNIT 1 

Introduction to Computer Hardware 

A computer is an electronic device, operating under the control of instructions stored in its 

own memory that can accept data (input), process the data according to specified rules, 

produce information (output), and store the information for future use. 

Characteristics of a Computer 

High Speed 

• Computer is a very fast device. 

• It is capable of performing calculation of very large amount of data. 

• The computer has units of speed in microsecond, nanosecond, and even the 

picosecond. 

• It can perform millions of calculations in a few seconds as compared to man who will 

spend many months to perform the same task. 

Accuracy 

• In addition to being very fast, computers are very accurate. 

• The calculations are 100% error free. 

• Computers perform all jobs with 100% accuracy provided that the input is correct. 

Storage Capability 

• Memory is a very important characteristic of computers. 

• A computer has much more storage capacity than human beings. 

• It can store large amount of data. 

• It can store any type of data such as images, videos, text, audio, etc. 

Diligence 

• Unlike human beings, a computer is free from monotony, tiredness, and lack of 

concentration. 

• It can work continuously without any error and boredom. 

• It can perform repeated tasks with the same speed and accuracy. 

Versatility 

• A computer is a very versatile machine. 

• A computer is very flexible in performing the jobs to be done. 

• This machine can be used to solve the problems related to various fields. 

• At one instance, it may be solving a complex scientific problem and the very next 

moment it may be playing a card game. 
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Reliability 

• A computer is a reliable machine. 

• Modern electronic components have long lives. 

• Computers are designed to make maintenance easy. 

Automation 

• Computer is an automatic machine. 

• Automation is the ability to perform a given task automatically. Once the computer 

receives a program i.e., the program is stored in the computer memory, then the 

program and instruction can control the program execution without human interaction. 

Reduction in Paper Work and Cost 

• The use of computers for data processing in an organization leads to reduction in paper 

work and results in speeding up the process. 

• As data in electronic files can be retrieved as and when required, the problem of 

maintenance of large number of paper files gets reduced. 

• Though the initial investment for installing a computer is high, it substantially reduces 

the cost of each of its transaction. 

FUNCTIONALITIES OF A COMPUTER 

Step 1 − Takes data as input. 

Step 2 − Stores the data/instructions in its memory and uses them as required. 

Step 3 − Processes the data and converts it into useful information. 

Step 4 − Generates the output. 

Step 5 − Controls all the above four steps. 

 

 

 

Applications of Computers 

A computer has high speed of calculation, diligence, accuracy, reliability, or versatility 

which has made it an integrated part in all business organizations. 

Computer is used in business organizations for − 
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• Payroll calculations 

• Budgeting 

• Sales analysis 

• Financial forecasting 

• Managing employee database 

• Maintenance of stocks, 

etc. Banking 

Today, banking is almost totally dependent on computers. 

Banks provide the following facilities − 

• Online accounting facility, which includes checking current balance, making deposits 

and overdrafts, checking interest charges, shares, and trustee records. 

• ATM machines which are completely automated are making it even easier for 

customers to deal with banks. 

Insurance 

Insurance companies are keeping all records up-to-date with the help of computers. Insurance 

companies, finance houses, and stock broking firms are widely using computers for their 

concerns. 

Insurance companies are maintaining a database of all clients with information showing − 

 

• Procedure to continue with policies 

• Starting date of the policies 

• Next due installment of a policy 

• Maturity date 

• Interests due 

• Survival benefits 

• Bonus 

Education 

The computer helps in providing a lot of facilities in the education system. 

• The computer provides a tool in the education system known as CBE (Computer 

Based Education). 

• CBE involves control, delivery, and evaluation of learning. 

• Computer education is rapidly increasing the graph of number of computer students. 

• There are a number of methods in which educational institutions can use a computer 

to educate the students. 

• It is used to prepare a database about performance of a student and analysis is carried 

out on this basis. 

Marketing 
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In marketing, uses of the computer are following − 

• Advertising − With computers, advertising professionals create art and graphics, write 

and revise copy, and print and disseminate ads with the goal of selling more products. 
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• Home Shopping − Home shopping has been made possible through the use of computerized catalogues that provide access to 

product information and permit direct entry of orders to be filled by the customers. 

Healthcare 

Computers have become an important part in hospitals, labs, and dispensaries. They are being used in hospitals to keep the record of 

patients and medicines. It is also used in scanning and diagnosing different diseases. ECG, EEG, ultrasounds and CT scans, etc. are 

also done by computerized machines. 

Following are some major fields of health care in which computers are used. 

• Diagnostic System − Computers are used to collect data and identify the cause of illness. 

• Lab-diagnostic System − All tests can be done and the reports are prepared by computer. 

• Patient Monitoring System − These are used to check the patient's signs for abnormality such as in Cardiac Arrest, ECG, etc. 

• Pharma Information System − Computer is used to check drug labels, expiry dates, harmful side effects, etc. 

• Surgery − Nowadays, computers are also used in performing surgery. Engineering Design 

Computers are widely used for Engineering purpose. 

One of the major areas is CAD (Computer Aided Design) that provides creation and modification of images. Some of the fields are − 

• Structural Engineering − Requires stress and strain analysis for design of ships, buildings, budgets, airplanes, etc. 

• Industrial Engineering − Computers deal with design, implementation, and improvement of integrated systems of people, 

materials, and equipment. 

• Architectural Engineering − Computers help in planning towns, designing buildings, determining a range of buildings on a site 

using both 2D and 3D drawings. 

Military 

Computers are largely used in defence. Modern tanks, missiles, weapons, etc. Military also employs computerized control systems. 

Some military areas where a computer has been used are − 

 

• Missile Control 

• Military Communication 

• Military Operation and Planning 
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• Smart Weapons Communication 

Communication is a way to convey a message, an idea, a picture, or speech that is received 

and understood clearly and correctly by the person for whom it is meant. Some main areas in this category are − 
 

• E-mail 

• Chatting 

• Usenet 

• FTP 

• Telnet 

• Video-conferencing Government 

Computers play an important role in government services. Some major fields in this category 
are − 

 

• Budgets 

• Sales tax department 

• Income tax department 

• Computation of male/female ratio 

• Computerization of voters lists 

• Computerization of PAN card 

• Weather forecasting 

• Generation in computer terminology is a change in technology a computer is/was being used. Initially, the generation term was 

used to distinguish between varying hardware technologies. Nowadays, generation includes both hardware and software, which 

together make up an entire computer system. 

• There are five computer generations known till date. Each generation has been discussed in detail along with their time period 

and characteristics. In the following table, approximate dates against each generation have been mentioned, which are normally 

accepted. 

GENERATION OF COMPUTERS 

 



 

 
 

8 
 

S.No Generation & Description 

 

1 
First Generation 

 

The period of first generation: 1946-1959. Vacuum tube based. 

 

2 
Second Generation 

The period of second generation: 1959-1965. Transistor based. 

 

3 
Third Generation 

The period of third generation: 1965-1971. Integrated Circuit based. 

 

4 
Fourth Generation 

The period of fourth generation: 1971-1980. VLSI microprocessor based. 

 

5 
Fifth Generation 

The period of fifth generation: 1980-onwards. ULSI microprocessor based. 

 

First Generation Computers: The period of first generation was from 1946-1959. The computers of first generation used vacuum tubes 

as the basic components for memory and circuitry for CPU (Central Processing Unit). These tubes, like electric bulbs, produced a lot of 

heat and the installations used to fuse frequently. Therefore, they were very expensive and only large organizations were able to afford 

it. In this generation, mainly batch processing operating system was used. Punch cards, paper tape, and magnetic tape was used as input 

and output devices. The computers in this generation used machine code as the programming language. The main features of the first 

generation are: Vacuum tube technology, Unreliable, Supported machine language only, Very costly, Generated a lot of heat, Slow input 

and output devices, Huge size, Need of AC, 15 Non-portable, Consumed a lot of electricity. 

Second Generation Computers: The period of second generation was from 1959-1965. In  this generation, transistors were used that 

were cheaper, consumed less power, more compact in size, more reliable and faster than the first generation machines made of vacuum 

tubes. In this generation, magnetic cores were used as the primary memory and magnetic tape and magnetic disks as secondary storage 

devices. In this generation, assembly language and high- level programming languages like FORTRAN, COBOL were used. The 

https://www.tutorialspoint.com/computer_fundamentals/computer_first_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_second_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_third_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fourth_generation.htm
https://www.tutorialspoint.com/computer_fundamentals/computer_fifth_generation.htm
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computers used batch processing and multiprogramming operating system. The main features of second generation are: Use of 

transistors, Reliable in comparison to first generation computers, Smaller size as compared to first generation computers, Generated less 

heat as compared to first generation computers, Consumed less electricity as compared to first generation computers, Faster than first 

generation computers, Still very costly, AC required, Supported machine and assembly languages. 

Third Generation Computers: The period of third generation was from 1965-1971. The computers of third generation used Integrated 

Circuits (ICs) in place of transistors. A single IC has many transistors, resistors, and capacitors along with the associated circuitry. The 

IC was invented by Jack Kilby. This development made computers smaller in size, reliable, and efficient. In this generation remote 

processing, time-sharing, multi-programming operating system were used. High-level languages (FORTRAN-II TO IV, COBOL, 

PASCAL PL/1, BASIC, ALGOL-68 etc.) were used during this generation. The main features of third generation are: IC used, More 

reliable in comparison to previous two generations, Smaller size, Generated less heat, Faster, Lesser maintenance, Costly, AC required, 

Consumed  lesser  electricity, Supported high-level language. 

Fourth Generation Computers: The period of fourth generation was from 1971-1980. Computers of fourth generation used Very Large 

Scale Integrated (VLSI) circuits. VLSI circuits having about 5000 transistors and 18 other circuit elements with their associated circuits 

on a single chip made it possible to have microcomputers of fourth generation. Fourth generation computers became more powerful, 

compact, reliable, and affordable. As a result, it gave rise to Personal Computer (PC) revolution. In this generation, time sharing, real 

time networks, distributed operating system were used. All the high-level languages like C, C++, DBASE etc., were used in this 

generation. The main features of fourth generation are: VLSI technology used, Very cheap, portable and reliable, Use of PCs, Very small 

size, Pipeline processing, No AC required, Concept of internet was introduced, and Great developments in the fields of networks, 

Computers became easily available. 

Fifth Generation Computers: The period of fifth generation is 1980-till date. In the fifth generation, VLSI technology became ULSI 

(Ultra Large Scale Integration) technology, resulting in the production of microprocessor chips having ten million electronic 

components. This generation is based on parallel processing hardware and AI (Artificial Intelligence) software. AI is an emerging branch 

in computer science, which interprets the means and method of making computers think like human beings. All the high-level languages 

like C and C++, Java, .Net etc., are used in this generation. AI includes: Robotics, Neural Networks, Game Playing and Development 

of expert systems to make decisions in real-life situations, Natural language understanding and generation 
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1 

 

Take Input 
The process of entering data and instructions into the computer 

system. 

 

2 

 

Store Data 
Saving data and instructions so that they are available for 

processing as and when required. 

 

3 

 

Processing Data 
Performing arithmetic, and logical operations on data in order to 

convert them into useful information. 

 

4 
Output 

Informatio

n 

The process of producing useful information or results for the user, 

such as a printed report or visual display. 

 

5 
Control the 

workflow 

Directs the manner and sequence in which all of the above 

operations are performed. 
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Input Unit 

This unit contains devices with the help of which we enter data into the computer. This unit creates a link between the user and the 

computer. The input devices translate the information into a form understandable by the computer. 

Following are some of the important input devices which are used in a computer − 

 

• Keyboard 

• Mouse 

• Joy Stick 

• Light pen 

• Track Ball 

• Scanner 

• Graphic Tablet 

• Microphone 

• Magnetic Ink Card Reader(MICR) 
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• Optical Character Reader(OCR) 

• Bar Code Reader 

• Optical Mark Reader(OMR) Keyboard 

Keyboard is the most common and very popular input device which helps to input data to the 
computer. The layout of the keyboard is like that of traditional typewriter, although there are some additional keys provided for 

performing additional functions. 

Keyboards are of two sizes 84 keys or 101/102 keys, but now keyboards with 104 keys or 108 keys are also available for Windows and 
Internet. 

The keys on the keyboard are as follows − 
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S.No Keys & Description 

 

1 
Typing Keys 

These keys include the letter keys (A-Z) and digit keys (09) which generally give 

the same layout as that of typewriters. 

 

 

2 

Numeric Keypad 

It is used to enter the numeric data or cursor movement. Generally, it consists of a 

set of 17 keys that are laid out in the same configuration used by most adding 

machines and calculators. 

 

 

3 

Function Keys 

The twelve function keys are present on the keyboard which are arranged in a row 

at the top of the keyboard. Each function key has a unique meaning and is used for 

some specific purpose. 

 

 

4 

Control keys 

These keys provide cursor and screen control. It includes four directional arrow 

keys. Control keys also include Home, End, Insert, Delete, Page Up, Page Down, 

Control(Ctrl), Alternate(Alt), Escape(Esc). 

 

5 
Special Purpose Keys 

Keyboard also contains some special purpose keys such as Enter, Shift, Caps Lock, 

Num Lock, Space bar, Tab, and Print Screen. 

Mouse 

Mouse is the most popular pointing device. It is a very famous cursor-control device having a small palm size box with a round ball at 

its base, which senses the movement of the mouse and sends corresponding signals to the CPU when the mouse buttons are pressed. 

Generally, it has two buttons called the left and the right button and a wheel is present between the buttons. A mouse can be used to 
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control the position of the cursor on the screen, but it cannot be used to enter text into the computer. 

Advantages 

 

• Easy to use 

• Not very expensive 

• Moves the cursor faster than the arrow keys of the keyboard.  

Joystick 

Joystick is also a pointing device, which is used to move the cursor position on a monitor 
screen. It is a stick having a spherical ball at its both lower and upper ends. The lower spherical ball moves in a socket. The 

joystick can be moved in all four directions.The function of the joystick is similar to that of a mouse. It is mainly used in 

Computer Aided Designing (CAD) and playing computer games. 

Light Pen 

Light pen is a pointing device similar to a pen. It is used to select a displayed menu item or draw pictures on the monitor screen. It 

consists of a photocell and an optical system placed in a small tube. When the tip of a light pen is moved over the monitor screen and 

the pen button is pressed, its photocell sensing element detects the screen location and sends the corresponding signal to the CPU. 

Track Ball 

Track ball is an input device that is mostly used in notebook or laptop computer, instead of a mouse. This is a ball which is half inserted 

and by moving fingers on the ball, the pointer can be moved. Since the whole device is not moved, a track ball requires less space than 

a mouse. A track ball comes in various shapes like a ball, a button, or a square. 

Scanner 

Scanner is an input device, which works more like a photocopy machine. It is used when some information is available on paper and it 

is to be transferred to the hard disk of the computer for further manipulation. Scanner captures images from the source which are then 

converted into a digital form that can be stored on the disk. These images can be edited before they are printed. 

Microphone 

Microphone is an input device to input sound that is then stored in a digital form. The microphone is used for various applications such 

 as adding sound to a multimedia presentation or for mixing music. 

Magnetic Ink Card Reader (MICR) 

MICR input device is generally used in banks as there are large number of cheques to be processed every day. The bank's code number 
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and cheque number are printed on the cheques with a special type of ink that contains particles of magnetic material that are machine 

readable. This reading process is called Magnetic Ink Character Recognition (MICR). The main advantages of MICR is that it is fast 

and less error prone. 

Bar Code Readers 

Bar Code Reader is a device used for reading bar coded data (data in the form of light and dark lines). Bar coded data is generally used 

in labelling goods, numbering the books, etc. It may be a handheld scanner or may be embedded in a stationary scanner. Bar Code 

Reader scans a bar code image, converts it into an alphanumeric value, which is then fed to the computer that the bar code reader is 

connected to. 

Central Processing Unit (CPU) consists of the following features − 

 

• CPU is considered as the brain of the computer. 

• CPU performs all types of data processing operations. 

• It stores data, intermediate results, and instructions (program). 

• It controls the operation of all parts of the computer. 

 

CPU itself has following three components. 

 

• Memory or Storage Unit 

• Control Unit 

• ALU(Arithmetic Logic Unit) 

 

Memory or Storage Unit 

This unit can store instructions, data, and intermediate results. This unit supplies information to other units of the computer when 

needed. It is also known as internal storage unit or the main memory or the primary storage or Random Access Memory (RAM). 

Its size affects speed, power, and capability. Primary memory and secondary memory are two types of memories in the computer. 

Functions of the memory unit are − 

• It stores all the data and the instructions required for processing. 

• It stores intermediate results of processing. 

• It stores the final results of processing before these results are released to an output device. 
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• All inputs and outputs are transmitted through the main memory. Memory is primarily of three types − 

• Cache Memory 

• Primary Memory/Main Memory 

• Secondary Memory Cache Memory 

Cache memory is a very high speed semiconductor memory which can speed up the CPU. It 
acts as a buffer between the CPU and the main memory. It is used to hold those parts of data and program which are most frequently 

used by the CPU. The parts of data and programs are transferred from the disk to cache memory by the operating system, from where 

the CPU can access them. 

Advantages 

The advantages of cache memory are as follows − 

 

• Cache memory is faster than main memory. 

• It consumes less access time as compared to main memory. 

• It stores the program that can be executed within a short period of time. 

• It stores data for temporary use. Disadvantages 

The disadvantages of cache memory are as follows − 

 

• Cache memory has limited capacity. 

• It is very expensive. Primary Memory (Main Memory) 

Primary memory holds only those data and instructions on which the computer is currently working. It has a limited capacity and data is 
 lost when power is switched off. It is generally made up of semiconductor device. These memories are not as fast as registers. The data 
 and instruction required to be processed resides in the main memory. It is divided into two subcategories RAM and ROM. 

 

 

Characteristics of Main Memory 

 

• These are semiconductor memories. 

• It is known as the main memory. 

• Usually volatile memory. 

• Data is lost in case power is switched off. 
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• It is the working memory of the computer. 

• Faster than secondary memories. 

• A computer cannot run without the primary memory. Secondary Memory 

This type of memory is also known as external memory or non-volatile. It is slower than the 
main memory. These are used for storing data/information permanently. CPU directly does not access these memories, instead they are 

accessed via input-output routines. The contents of secondary memories are first transferred to the main memory, and then the CPU 

can access it. For example, disk, CD-ROM, DVD, etc. 

Characteristics of Secondary Memory 

 

• These are magnetic and optical memories. 

• It is known as the backup memory. 

• It is a non-volatile memory. 

• Data is permanently stored even if power is switched off. 

• It is used for storage of data in a computer. 

• Computer may run without the secondary memory. 

• Slower than primary memories. 

RAM (Random Access Memory) is the internal memory of the CPU for storing data, program, and program result. It is a read/write 

memory which stores data until the machine is working. As soon as the machine is switched off, data is erased. 

Access time in RAM is independent of the address, that is, each storage location inside the memory is as easy to reach as other locations 

and takes the same amount of time. Data in the RAM can be accessed randomly but it is very expensive. 

RAM is volatile, i.e. data stored in it is lost when we switch off the computer or if there is a power failure. Hence, a backup 

Uninterruptible Power System (UPS) is often used with computers. RAM is small, both in terms of its physical size and in the amount 

of data it can hold. 

 

RAM is of two types − 

 

• Static RAM (SRAM) 

• Dynamic RAM (DRAM) Static RAM (SRAM) 

The word static indicates that the memory retains its contents as long as power is being 
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supplied. However, data is lost when the power gets down due to volatile nature. SRAM chips use a matrix of 6-transistors and no 

capacitors. Transistors do not require power to prevent leakage, so SRAM need not be refreshed on a regular basis. 

There is extra space in the matrix, hence SRAM uses more chips than DRAM for the same amount of storage space, making the 

manufacturing costs higher. SRAM is thus used as cache memory and has very fast access. 

Characteristic of Static RAM 

 

• Long life 

• No need to refresh 

• Faster 

• Used as cache memory 

• Large size 

• Expensive 

• High power consumption Dynamic RAM (DRAM) 

DRAM, unlike SRAM, must be continually refreshed in order to maintain the data. This is done 
by placing the memory on a refresh circuit that rewrites the data several hundred times per second. DRAM is used for most system 

memory as it is cheap and small. All DRAMs are made up of memory cells, which are composed of one capacitor and one transistor. 

Characteristics of Dynamic RAM 

 

• Short data lifetime 

• Needs to be refreshed continuously 

• Slower as compared to SRAM 

• Used as RAM 

• Smaller in size 

• Less expensive 

• Less power consumption 

ROM stands for Read Only Memory. The memory from which we can only read but cannot write on it. This type of memory is non-

volatile. The information is stored permanently in such memories during manufacture. A ROM stores such instructions that are required 

to start a computer. This operation is referred to as bootstrap. ROM chips are not only used in the computer but also in other electronic 

items like washing machine and microwave oven. 



 

 
 

19 
 

Let us now discuss the various types of ROMs and their characteristics. 

 

MROM (Masked ROM) 

The very first ROMs were hard-wired devices that contained a pre-programmed set of data or instructions. These kind of ROMs are 
known as masked ROMs, which are inexpensive. 

PROM (Programmable Read Only Memory) 

PROM is read-only memory that can be modified only once by a user. The user buys a blank PROM and enters the desired contents 

using a PROM program. Inside the PROM chip, there are small fuses which are burnt open during programming. It can be programmed 

only once and is not erasable. 

EPROM (Erasable and Programmable Read Only Memory) 

EPROM can be erased by exposing it to ultra-violet light for a duration of up to 40 minutes. Usually, an EPROM eraser achieves this 

function. During programming, an electrical charge is trapped in an insulated gate region. The charge is retained for more than 10 years 

because the charge has no leakage path. For erasing this charge, ultra-violet light is passed through a quartz crystal window (lid). This 

exposure to ultra-violet light dissipates the charge. During normal use, the quartz lid is sealed with a sticker. 

EEPROM (Electrically Erasable and Programmable Read Only Memory) 

EEPROM is programmed and erased electrically. It can be erased and reprogrammed about ten thousand times. Both erasing and 

programming take about 4 to 10 ms (millisecond). In EEPROM, any location can be selectively erased and programmed. EEPROMs 

can be erased one byte at a time, rather than erasing the entire chip. Hence, the process of reprogramming is flexible but slow. 

Advantages of ROM 

The advantages of ROM are as follows − 

 

• Non-volatile in nature 

• Cannot be accidentally changed 

• Cheaper than RAMs 

• Easy to test 

• More reliable than RAMs 

• Static and do not require refreshing 

• Contents are always known and can be verified Differences between RAM and ROM 
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DIFFERENC

E 

RA

M 

RO

M 

 

 

Working type 

Data stored in RAM can be 

retrieved and altered. 

Data stored in ROM can only be 

read. 

 

 

 

 

Use 

Used to store the data that has to 

be currently processed by CPU 

temporarily. 

It stores the instructions required 

during bootstrap of the computer. 

Speed It is a high-speed memory. It is much slower than the RAM. 

 

 

CPU 

 

Interaction 

 

 

The CPU can access the data 

stored on it. 

The CPU can not access the data 

stored on it unless the data is stored 

in RAM. 

Size and 

Capacity 

 

 

Large size with higher capacity. 

 

 

Small size with less capacity. 

Used as/in CPU Cache, Primary memory. Firmware, Micro-controllers 

 



 

 
 

21 
 

 

 

Accessibility 

The data stored is easily 

accessible 

The data stored is not as easily 

accessible as in RAM 

Cost Costlier cheaper than RAM. 

 

 

 

Control Unit 

This unit controls the operations of all parts of the computer but does not carry out any actual data processing operations. 

Functions of this unit are − 

 

• It is responsible for controlling the transfer of data and instructions among other units of a computer. 

• It manages and coordinates all the units of the computer. 

• It obtains the instructions from the memory, interprets them, and directs the operation of the computer. 

• It communicates with Input/Output devices for transfer of data or results from storage. 

• It does not process or store data. 

ALU (Arithmetic Logic Unit) 

This unit consists of two subsections namely, 

 

• Arithmetic Section 

• Logic Section 

Arithmetic Section 

Function of arithmetic section is to perform arithmetic operations like addition, subtraction, multiplication, and division. All complex 

operations are done by making repetitive use of the above operations. 

Logic Section 

Function of logic section is to perform logic operations such as comparing, selecting, matching, and merging of data. 
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Output Unit 

The output unit consists of devices with the help of which we get the information from the computer. This unit is a link between the 

computer and the users. Output devices translate the computer's output into a form understandable by the users. 

Following are some of the important output devices used in a computer. 

 

• Monitors 

• Graphic Plotter 

• Printer Monitors 

Monitors, commonly called as Visual Display Unit (VDU), are the main output device of a 
computer. It forms images from tiny dots, called pixels that are arranged in a rectangular form. The sharpness of the image depends 

upon the number of pixels. 

• Size − It is the diagonal size of the LCD screen. Larger the area, bigger the picture screen. A bigger picture is preferable for 

movie watching and gaming. It will increase the productivity as well. 

• Resolution − This is the number of pixels on the screen. For example, 24inch display is 1920x1200 (width by length) and 22-

inch display is 1680x1050. High resolution provides better picture quality and a nice gaming experience. 

• Inputs − Now-a-days monitors can accept inputs from cable as well apart from the computer. They can also have USB ports. 

• Stand − Some monitors come with adjustable stands while some may not. 

• Recommended − 24 Inch LCD. 

There are two kinds of viewing screen used for monitors. 

 

• Cathode-Ray Tube (CRT) 

• Flat-Panel Display Cathode-Ray Tube (CRT) Monitor 

The CRT display is made up of small picture elements called pixels. The smaller the pixels, the 
better the image clarity or resolution. It takes more than one illuminated pixel to form a whole character, such as the letter ‘e’ in the 

word help. 

A finite number of characters can be displayed on a screen at once. The screen can be divided into a series of character boxes - fixed 

location on the screen where a standard character can be placed. Most screens are capable of displaying 80 characters of data 

horizontally and 25 lines vertically. 
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There are some disadvantages of CRT − 

 

• Large in Size 

• High power consumption Flat-Panel Display Monitor 

The flat-panel display refers to a class of video devices that have reduced volume, weight and 
power requirement in comparison to the CRT. You can hang them on walls or wear them on your wrists. Current uses of flat-panel 

displays include calculators, video games, monitors, laptop computer, and graphics display. 

The flat-panel display is divided into two categories − 

• Emissive Displays − Emissive displays are devices that convert electrical energy into light. For example, plasma panel and LED 

(Light-Emitting Diodes). 

• Non-Emissive Displays − Non-emissive displays use optical effects to convert sunlight or light from some other source into 

graphics patterns. For example, LCD (Liquid- Crystal Device). 

Printers 

Printer is an output device, which is used to print information on paper. There are two types of printers − 

• Impact Printers 

• Non-Impact Printers Impact Printers 

Impact printers print the characters by striking them on the ribbon, which is then pressed on the 
paper. 

Characteristics of Impact Printers are the following − 

 

• Very low consumable costs 

• Very noisy 

• Useful for bulk printing due to low cost 

 

• There is physical contact with the paper to produce an image These printers are of two types − 

• Character printers 

• Line printers 
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Character Printers 

Character printers are the printers which print one character at a time. These are further divided into two 

types: 

• Dot Matrix Printer(DMP) 

• Daisy Wheel 

Dot Matrix Printer 

A Dot Matrix Printer or Impact Matrix Printer refers to a type of computer printer with a print head that runs back and forth on the 

page and prints by impact, striking an ink-soaked cloth ribbon against the paper, much like a typewriter. Unlike a typewriter or daisy 

wheel printer, letters are drawn out of a dot matrix, and thus, varied fonts and arbitrary graphics can be produced. 

Because the printing  involves  mechanical  pressure,  these  printers  can  create carbon copies and carbonless copies. Each dot is 

produced by a tiny metal rod, also called a "wire" or "pin", which is driven forward by the power of a tiny electromagnet or solenoid, 

either directly or through small levers (pawls). Facing the ribbon and the paper is a small guide plate pierced with holes to serve as 

guides for the pins. The moving portion of the  printer is  called  the  print head, and when running the printer as a generic text device it 

generally prints one line of text at a time. 

Most dot matrix printers have a single vertical line of dot making equipment on their print heads; others have a few interleaved rows in 

order to improve dot density. These machines can be highly durable, but eventually wear out. Ink invades the guide plate of the print 

head, causing grit to adhere to it; this grit slowly causes the channels in the guide plate to wear from circles into ovals or slots, providing 

less and less accurate guidance to the printing wires. 

 

 

Advantages 

 

• Inexpensive 

• Widely Used 

• Other language characters can be printed 

Disadvantages 

 

• Slow Speed 

• Poor Quality 
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Line Printers 

Line printers are the printers which print one line at a time. Examples are 

• Drum Printer 

• Chain Printer 

Non-impact Printers 

Non-impact printers print the characters without using the ribbon. These printers print a complete page at a time, thus they are also 

called as Page Printers. 

These printers are of two types − 

 

• Laser Printers 

• Inkjet Printers 

Characteristics of Non-impact Printers 

 

• Faster than impact printers 

• They are not noisy 

• High quality 

• Supports many fonts and different character size 

Laser Printers 

These are non-impact page printers. They use laser lights to produce the dots needed to form the characters to be printed on a page. 

A laser printer makes use of a beam of light for printing. This light of the laser changes the electrical charge on the drum, wherever it 

hits because as the paper passes through the printer, the laser beam strikes at the surface of the drum and this is known as a photoreceptor. 

By changing the charge on the drum, the laser beam can print patterns onto the photoreceptor. Once the design created on the drum, it 

coated with  toner from a toner cartridge. In  most of  the cartridges, the toner is black, but the laser printers are also colored. 

Laser printers work by laying down an array of tiny, evenly spaced dots of "ink" on the paper. The dots are so small, and they blend so 

seamlessly that text looks very nearly as clean as  what you get from a traditional typesetting machine. Yes, there are little-jagged edges 

along curved lines, but they're hard to see. Graphics sometimes don't turn out quite as sharp, but they still are bright enough for a 

professional look in many situations. 

The quality you get from your laser printer depends mostly on the resolution, the fineness of the dots it uses to print the images. 
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Resolution measured in dots per inch (dpi), which is how many dots it can write along with a line, either vertically or horizontally. Most 

laser printers have had 300 dpi resolutions 

 

 

Advantages 

 

• Very high speed 

• Very high quality output 

• Good graphics quality 

• Supports many fonts and different character size 

Disadvantages 

 

• Expensive 

• Cannot be used to produce multiple copies of a document in a single printing 

Inkjet Printers 

Inkjet printers are non-impact character printers based on a relatively new technology. They print characters by spraying small drops 

of ink onto paper. Inkjet printers produce high quality output with presentable features. 

They make less noise because no hammering is done and these have many styles of printing modes available. Color printing is also 

possible. Some models of Inkjet printers can produce multiple copies of printing also. 

Advantages 

 

• High quality printing 

• More reliable 

Disadvantages 

 

• Expensive as the cost per page is high 

• Slow as compared to laser printer 

 

Difference between Impact and Non-Impact Printers 
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Impact Non-Impact 

Produces text and images when tiny wire 

pins on print head strike the ink ribbon by 

physically contacting the paper 

Produces text and graphics on paper 

without actually striking the paper(no 

physically contact to paper) 
Uses ink ribbon Uses ink spray 

Print quality lower in some types High quality of output, capable of 

printing fine and smooth details 

Low printing speed Reasonably fast 

Generally noise because of the striking 

activity 

Low noise because there is no striking 

mechanism 

Not commonly used today Most commonly used printer today 

 

 

A memory is just like a human brain. It is used to store data and instructions. Computer memory is the storage space in the computer, 

where data is to be processed and instructions required for processing are stored. The memory is divided into large number of small 

parts called cells. Each location or cell has a unique address, which varies from zero to memory size minus one. For example, if the 

computer has 64k words, then this memory unit has 64 * 1024 = 65536 memory locations. The address of these locations varies from 

0 to 65535. 
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Hardwar

e 

Software 

             

It is the physical component of a computer 

system. 

It is the programming language that 

makes hardware functional. 

It has the permanent shape and structure, 

which cannot be modified. 

It can be modified and reused, as it has 

no permanent shape and structure. 

The external agents such as dust, mouse, 

insects, humidity, heat, etc. can affect the 

hardware (as it is tangible). 

The external agents such as dust, 

mouse, insects, humidity, heat, etc. 

cannot affect (as it is not tangible). 

It works with binary code (i.e., 1’s to 0’s) . It functions with the help of high level 

language like COBOL, BASIC, 

JAVA, etc. 

It takes in only machine language, i.e., lower 

level language. 

It takes in higher level language, easily 

readable by a human being. 

It is not affected by the computer bug or virus. It is affected by the computer bug or 

virus. 

It cannot be transferred from one place to other 
electronically. 

It can transfer from one place to other 
electronically. 
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Duplicate copy of hardware cannot be created. A user can create copies of a software 
as many as he wishes. 

 

3. ASSEMBLING A PERSONAL COMPUTER Monitor 

 Size − It is the diagonal size of the LCD screen. Larger the area, bigger the picture screen. A bigger picture is preferable for 

movie watching and gaming. It will increase the productivity as well. 

 Resolution − This is the number of pixels on the screen. For example, 24inch display is 1920x1200 (width by length) and 22-

inch display is 1680x1050. High resolution provides better picture quality and a nice gaming experience. 

 Inputs − Now-a-days monitors can accept inputs from cable as well apart from the computer. They can also have USB ports. 

 Stand − Some monitors come with adjustable stands while some may not. 

 Recommended − 24 Inch LCD. 

Operating System 

 Operating System is the main software of the computer as everything will run on it in one form or other. 

 There are primarily three choices: Windows, Linux, Apple OS X. 

 Linux is free, however people generally do not use it for home purpose. 

 Apple OS X works only on Apple desktops. 

 Windows 7 is very popular among desktop users. 

 Most of the computers come pre-equipped with Windows 7 Starter edition. 

 Windows 8 is recently introduced and is available in the market. 

 Windows 7 and Windows 8 come in multiple versions from starter, home basic, home premium, professional, ultimate, and 

enterprise editions. 

 As the edition version increases, their features list and price increases. 

 Recommended − Windows 7 Home Premium. 
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Optical Drive (CD / DVD / Blu-ray) 

 Optical drive is the drive on a computer, which is responsible for using CD, DVD, and Blu-ray discs. 

 Now-a-days, DVD burners are industry standards. 

 DVD Burner can burn CD, DVD and play them. 

 DVD Burner is cheaper than Blu-ray drives. 

 Blu-ray drives can play HD movies but are costlier component. 

 Recommended − DVD Burner. 

Memory 

 RAM is considered as Computer Memory as the performance of a computer is directly proportional to its memory and 

processor. 

 Today's software and operating system require high memory. 

 Today commonly used RAM is DDR3, which operates at 1066Mhz. 

 As per Windows 7, 1 GB is the minimum RAM required to function properly. 

 Recommended − 4 GB. 

Hard Drive 

 Hard disk is used for storage purpose. Higher the capacity, more data you can save in  it. 

 Now-a-days computers are equipped with 500GB hard drive, which can be extended to 2TB. 

 Most hard drives in desktop operate at the standard performance speed of 7200RPM. 

 

 Recommended − 500GB. 

CPU 

 Frequency (GHz) − This determines the speed of the processor. More the speed, better the CPU. 

 Cores − Now-a-days CPUs come with more than one core, which is like having more than one CPU in the computer. Programs 

which can take advantage of multi-core environment will run faster on such machines. 

 Brand − Intel or AMD. Both are equivalent. Intel is in lead. 
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 Cache − Higher the L1, L2 cache, better the CPU performance. 

 Recommended − Intel Core i3-3225 3.30 GHz Processor. 

 

HARD DISK PARTITIONING 

 

In order to use a hard drive, or a portion of a hard drive, in Windows you need to first partition it and then format it. This 

process will then assign a drive letter to the partition allowing you to access it in order to use it to store and retrieve data. 

What is a hard disk partition 

 

When a hard drive is installed in a computer, it must be partitioned before you can format and use it. Partitioning a drive is 

when you divide the total storage of a drive into different pieces. These pieces are called partitions. Once a partition is created, it can 

then be formatted so that it can be used on a computer. When partitions are made, you specify the total amount of storage that you 

would like to allocate to that partition from the total size of the drive. For example, if you have an 80 GB drive, then it would be 

possible to make one partition consisting of the entire 80 GB of available storage. Alternatively,you could make two partitions 

consisting of a 20 GB partition that will be used for the operating system and programs and a 60 GB partition set aside for data, 

music, and images. 

 

In the current IBM PC architecture, there is a partition table in the drive's Master Boot Record (section of the hard drive that 

contains the commands necessary to start the operating system), or MBR, that lists information about the partitions on the hard drive. 

This partition table is then further split into 4 partition table entries, with each entries corresponding to a partition. 
Due to this it is only possible to have four partitions. These 4 partitions are typically known 

as primary partitions. To overcome this restriction, system developers decided to add a new type of partition called the extended 

partition. By replacing one of the four primary partitions with an extended partition, you can then make an additional 24 logical 

partitions within the extended one. The table below illustrates this. 

 
Partition Table 

Primary Partition #1 
Primary Partition #2 
Primary Partition #3 
Primary Partition #4 
(Extended Partition) 

Logical Partition #1 
Logical Partition #1 
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As you can see, this partition table is broken up into 4 primary partitions. The fourth partition, though, has been flagged as an 

extended partition. This allows us to make more logical partitions under that extended partition and therefore bypassing the 4 partition 

limit. 

 

Each hard drive also has one of its possible 4 partitions flagged as an active partition. 

The active partition is a special flag assigned to only one partition on a hard drive that the Master Boot Record (MBR) uses to boot 

your computer into an operating system. As only one partition may be set as the active partition, you may be wondering how people 

can have multiple operating systems installed on different partitions, and yet still be able to use them all. This is accomplished by 

installing a boot loader in the active partition. When the computer starts, it will read the MBR and determine the partition that is 

flagged as active. This partition is the one that contains the boot loader. When the operating system boots off of this partition the boot 

loader will start and allow you to choose which operating systems you would like to boot from. 

 

Why make partitions 

 

Now that you know what a partition is, you may be wondering why you would even need to make multiple partitions instead of 

just making one. Though there are quite a few reasons, we will touch on some of the more important ones below: 

 

▪ Multiple Filesystems - When you create a partition, you then need to format it before it can be used. When formatting 

a partition you tell the operating system what filesystem you would like that partition to be formatted in. Once you 

format a partition, and therefore assign the type of filesystem you want to use with it, you can not change that 

filesystem without formatting the partition again and losing all the data contained on it. If you require different 

filesystems on your computer, whether it be for security or for a specific application, you can then make multiple 

partition and assign one type of filesystem to one of the partitions and another to one of the other partitions. 

▪ Partition Size - On older operating systems the maximum size of a partition was limited. Therefore if you had more 

storage space on a hard drive than was usable in a single partition, you would need to create other partitions to utilize 

this unused space. 

▪ Multiple Operating Systems - Some operating systems use filesystems that are not compatible with other operating 

systems. If you want to use two operating systems on the same computer that are not compatible in this way, you could 

then make two partitions, one for each operating system. Then a boot loader could be used to switch between them when 

you start your computer. 

▪ Wasted disk Space - When a filesystems store data in a partition, the larger the partition, the greater the chance of 

wasted space. By having multiple partitions of smaller size, you reduce the amount of waste that filesystems may create. 
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▪ Seperate system files from users files - Some components of an operating system require storage space to operate. For 

example, in Windows if you have no hard drive space available on the drive that Windows is installed on, you will not 

be able to print. By creating a partition solely devoted to the operating system and then another partition dedicated to 

your own data and programs, there is less of a chance of you using up the space on the operating system partition with 

your data, and thus not causing problems. 

 

Creating and formatting a partition in Windows 

 

Before you can partition a hard drive in Windows, you must have installed a new unused hard disk, deleted an existing 

partition, or have some unpartitioned space available on an existing drive. In the example in this tutorial I will take the unused space 

from one of my hard drives and partition/format it. The steps shown here will work whether you are working with a brand new hard 

drive, deleting an existing partition and reusing it, or partitioning available space on an existing hard drive. 

 

All hard disk management is done in the Disk Management Administrative Tool. Follow these steps to open this tool: 

1. If you are using Windows 8, type Disk Management at the start screen, click 

on Settings, and then click on the Create and format hard disk partitions option. Then skip to step 3. Otherwise, click on the Start 
button and select the Control Panel option. 

2. If in Classic control panel mode, double-click on the Administrative Tools icon and then double-click on Computer 

Management icon. 

If your control panel is in the Category view, click on Performance and Maintenance, then click on Administrative Tools, and finally 
double-click on the Computer Management icon. 

3. When the Computer Management screen opens, click on the Disk 

Management option under the Storagecategory. This will present you with a screen similar to the one below. 

https://www.bleepingcomputer.com/tutorials/partition-and-format-a-disk-in-windows/#delete
https://www.bleepingcomputer.com/tutorials/partition-and-format-a-disk-in-windows/#delete


 

 
 

34 
 

 

The Disk Management Screen 

When you are in the disk management tool you will see a listing of your current hard drives and how they are partitioned. 

From the image above you can see that I have two hard disks installed. The first disk, Disc 0, has two partitions. One partition is a 24 

GB NTFS partition that has been assigned the drive letter C:. The other partition on that drive is a 87 GB NTFS partition that has 

been assigned the drive letter E:. The other drive, has only one partition, the D: partition. The rest of the space, 26 GB, shows that it is 

unallocated and therefore can be used to make other partitions. 

To make a partition from the unused space you would do the following. 

1. Right click on the space listed as unallocated. 

2. At the menu that comes up, click on the New Partition option. 

3. You will now be presented with a wizard as to how you would like the partition to be created. At the first screen press Next. 

4. At the following screen, determine if you need a primary or extended partition. For more information about these 

partitions you can read our partition tutorial listed above. Most people will be fine selecting Primary Partition. Select Primary 

Partition and press Next. 

5. At the next screen you will be prompted to type in how much of the unallocated space you would like used for the new 

partition. In my example, my unallocated space is 26.43 GB, so I can choose to make a partition of that entire amount of only use half 

and save the rest for another partition. Regardless, of what you decide, you need to enter a size in the Partition size in MB: field, or 
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stick with the default size, and press the Next button. 

6. At the next screen select the drive letter you would like assigned to it, or use the default one given. When done, press the 

Next button. The drive letter that you assign here will be how you access the partition later. 

7. In this step you will determine how you would like the new partition to be formatted. For the most part you are advised to 

use the NTFS file system. If you need a file system that can be readable by older operating systems like DOS, Windows 95, 

Windows 98, or Windows ME, then you should instead choose the FAT32 file system. 

8. Type a name in the Volume Label field that will be associated with this partition or leave it blank. 

9. Finally press the Next button and you will come to a summary screen. Review how the partition will be created, and if you are 

satisfied, press the Finish button to complete the creation and formatting of your new hard disk partition. 

When the computer finishes creating and formatting the new partition you will be presented with the Disk Management screen 

again and will see that you have a new partition and drive letter on your computer. Now you can use that drive to start storing your 

data. 

 

Deleting a partition in Windows 

 

If you have existing partitions on your computer that you would like to delete in order to use its space for other purposes, then 

you first need to delete this partition. It is important to note that by deleting a partition you will lose all your data on that partition. 

With that warning given, let me give some examples of why you would want to delete a partition. Lets say that you have a 60 GB 

hard drive in your computer that was originally partitioned into a 20 GB partition and a 40 GB partition. You would like to install 

another operating system on your computer, but feel that neither partition is big enough on its own, and would like to instead create 

one partition using the full storage of 60 GB. The only way to do that would be to delete both of the existing partitions and recreate a 

new one using all the available space. 
To delete a partition please follow these steps: 

1. Click on the Start button and select the Control Panel option. 

2. If in Classic control panel mode, double-click on the Administrative Tools icon and then double-click on Computer 

Management icon. 

If your control panel is in the Category view, click on Performance and Maintenance, then click on Administrative Tools, 

and finally double-click on the Computer Management icon. 

3. When the Computer Management screen opens, click on the Disk Management option under the 

Storagecategory. 

4. Right-click on the partition you would like to delete and choose the Delete Partition option. 

5. A confirmation box will come up asking if you are sure you would like to continue. If you press the yes button, all data on 

this partition will be deleted. If you are sure about deleting this partition, press the Yes button. 
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The partition will now be deleted and you can either create a new partition or exit the program. 

 

Components of A Motherboard 

 RAM 
 ROM 
 Microprocessor 
 Floppy Disk Drive 
 Monitor/Keyboard/Networking Ports 
 Sound Card 
 Video/Graphics Card 
 Data Bus 

 

Features of Motherboard 

A motherboard comes with following features − 

 Motherboard varies greatly in supporting various types of components. 

 Motherboard supports a single type of CPU and few types of memories. 

 Video cards, hard disks, sound cards have to be compatible with the motherboard to function properly. 

 Motherboards, cases, and power supplies must be compatible to work properly together. 

Description of Motherboard 

The motherboard is mounted inside the case and is securely attached via small screws through pre-drilled holes. Motherboard contains 

ports to connect all of the internal components. It provides a single socket for CPU, whereas for memory, normally one or more slots 

are available. Motherboards provide ports to attach the floppy drive, hard drive, and optical drives via ribbon cables. Motherboard 

carries fans and a special port designed for power supply. 

There is a peripheral card slot in front of the motherboard using which video cards, sound cards, and other expansion cards can be 

connected to the motherboard. 

On the left side, motherboards carry a number of ports to connect the monitor, printer, mouse, keyboard, speaker, and network cables. 

Motherboards also provide USB ports, which allow compatible devices to be connected in plug-in/plug-out fashion. For example, pen 

drive, digital cameras, etc. 

https://www.bleepingcomputer.com/tutorials/partition-and-format-a-disk-in-windows/#create
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Memory unit is the amount of data that can be stored in the storage unit. This storage capacity is expressed in terms of Bytes. 

The following table explains the main memory storage units − 

 

S.No. Unit & 

Description 

1 Bit (Binary Digit) 

A binary digit is logical 0 and 1 representing a passive or an active state of a 

 
component in an electric circuit. 

 

2 
Nibble 

A group of 4 bits is called nibble. 

 

 

3 

Byte 

A group of 8 bits is called byte. A byte is the smallest unit, which can represent a data 

item or a character. 

 

 

 

4 

Word 

A computer word, like a byte, is a group of fixed number of bits processed as a unit, 

which varies from computer to computer but is fixed for each computer. 

The length of a computer word is called word-size or word length. It may be as small 

as 8 bits or may be as long as 96 bits. A computer stores the information in the form 

of computer words. 

The following table lists some higher storage units − 
 

S.No. Unit & Description 
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1 
Kilobyte (KB) 

1 KB = 1024 Bytes 

 

2 
Megabyte (MB) 

1 MB = 1024 KB 

 

3 
GigaByte (GB) 

1 GB = 1024 MB 

 

4 
TeraByte (TB) 

1 TB = 1024 GB 

 

5 
PetaByte (PB) 

1 PB = 1024 TB 

A port is a physical docking point using which an external device can be connected to the computer. It can also be programmatic 

docking point through which information flows from a program to the computer or over the Internet. 

 

Characteristics of Ports 

A port has the following characteristics − 

 External devices are connected to a computer using cables and ports. 

 Ports are slots on the motherboard into which a cable of external device is plugged in. 

 Examples of external devices attached via ports are the mouse, keyboard, monitor, microphone, speakers, etc. 
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Let us now discuss a few important types of ports − Serial Port 

 Used for external modems and older computer mouse 

 Two versions: 9 pin, 25 pin model 

 Data travels at 115 kilobits per second Parallel Port 

 Used for scanners and printers 

 Also called printer port 

 25 pin model 

 IEEE 1284-compliant Centronics port PS/2 Port 

 Used for old computer keyboard and mouse 
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 Also called mouse port 

 Most of the old computers provide two PS/2 port, each for the mouse and keyboard 

 IEEE 1284-compliant Centronics port 

Universal Serial Bus (or USB) Port 

 It can connect all kinds of external USB devices such as external hard disk, printer, scanner, mouse, keyboard, etc. 

 It was introduced in 1997. 

 Most of the computers provide two USB ports as minimum. 

 Data travels at 12 megabits per seconds. 

 USB compliant devices can get power from a USB port. VGA Port 

 Connects monitor to a computer's video card. 

 It has 15 holes. 

 Similar to the serial port connector. However, serial port connector has pins, VGA port has holes. 

Power Connector 

 Three-pronged plug. 

 Connects to the computer's power cable that plugs into a power bar or wall socket. Firewire Port 

 Transfers large amount of data at very fast speed. 

 Connects camcorders and video equipment to the computer. 

 Data travels at 400 to 800 megabits per seconds. 

 Invented by Apple. 

 It has three variants: 4-Pin FireWire 400 connector, 6-Pin FireWire 400 connector, and 9-Pin FireWire 800 connector. 

Modem Port 

 

 Connects a PC's modem to the telephone network. Ethernet Port 

 Connects to a network and high speed Internet. 

 Connects the network cable to a computer. 



 

 
 

41 
 

 This port resides on an Ethernet Card. 

 Data travels at 10 megabits to 1000 megabits per seconds depending upon the network bandwidth. 

Game Port 

 Connect a joystick to a PC 

 Now replaced by USB 

 

Digital Video Interface, DVI port 

 Connects Flat panel LCD monitor to the computer's high-end video graphic cards. 

 Very popular among video card manufacturers. Sockets 

 Sockets connect the microphone and speakers to the sound card of the computer. 

Hardware represents the physical and tangible components of a computer, i.e. the components that can be seen and touched. 

Relationship between Hardware and Software 

 Hardware and software are mutually dependent on each other. Both of them must work together to make a computer produce a 

useful output. 

 Software cannot be utilized without supporting hardware. 

 Hardware without a set of programs to operate upon cannot be utilized and is useless. 

 To get a particular job done on the computer, relevant software should be loaded into the hardware. 

 Hardware is a one-time expense. 

 Software development is very expensive and is a continuing expense. 

 Different software applications can be loaded on a hardware to run different jobs. 

 A software acts as an interface between the user and the hardware. 

 If the hardware is the 'heart' of a computer system, then the software is its 'soul'. Both are complementary to each other. 

Software is a set of programs, which is designed to perform a well-defined function. A program is a sequence of instructions written 

to solve a particular problem. 

There are two types of software − 
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 System Software 

 Application Software System Software 

The system software is a collection of programs designed to operate, control, and extend the 

processing capabilities of the computer itself. System software is generally prepared by the computer manufacturers. These software 

products comprise of programs written in low-level languages, which interact with the hardware at a very basic level. System software 

serves as the interface between the hardware and the end users. 

Some examples of system software are Operating System, Compilers, Interpreter, Assemblers, etc. 

Here is a list of some of the most prominent features of a system software − 

 

 Close to the system 

 Fast in speed 

 Difficult to design 

 Difficult to understand 

 Less interactive 

 Smaller in size 

 Difficult to manipulate 

 Generally written in low-level language Application Software 

Application software products are designed to satisfy a particular need of a particular 
environment. All software applications prepared in the computer lab can come under the category of Application software. 

Application software may consist of a single program, such as Microsoft's notepad for writing and editing a simple text. It may also 

consist of a collection of programs, often called a software package, which work together to accomplish a task, such as a spreadsheet 

package. 

Examples of Application software are the following − 

 

 Payroll Software 

 Student Record Software 

 Inventory Management Software 
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 Income Tax Software 

 Railways Reservation Software 

 Microsoft Office Suite Software 

 Microsoft Word 

 Microsoft Excel 

 Microsoft PowerPoint 

 

Features of application software are as follows − 

 

 Close to the user 

 Easy to design 

 More interactive 

 Slow in speed 

 Generally written in high-level language 

 Easy to understand 

 Easy to manipulate and use 

 Bigger in size and requires large storage space 

A computer network is a system in which multiple computers are connected to each other to share information and resources. 

Characteristics of a Computer Network 

 Share resources from one computer to another. 

 Create files and store them in one computer, access those files from the other computer(s) connected over the network. 

 

 Connect a printer, scanner, or a fax machine to one computer within the network and let other computers of the network use 

the machines available over the network. 

Following is the list of hardware's required to set up a computer network. 

 

 Network Cables 

 Distributors 
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 Routers 

 Internal Network Cards 

 External Network Cards Network Cables 

Network cables are used to connect computers. The most commonly used cable is Category 5 
cable RJ-45. 

 

 

Distributors 

A computer can be connected to another one via a serial port but if we need to connect many computers to produce a network, this 

serial connection will not work. 

 

The solution is to use a central body to which other computers, printers, scanners, etc. can be connected and then this body will 

manage or distribute network traffic. 

Router 



 

 
 

45 
 

A router is a type of device which acts as the central point among computers and other devices that are a part of the network. It is 

equipped with holes called ports. Computers and other devices are connected to a router using network cables. Now-a-days router 

comes in wireless modes using which computers can be connected without any physical cable. 

 
 

Network Card 

Network card is a necessary component of a computer without which a computer cannot be connected over a network. It is also known 

as the network adapter or Network Interface Card (NIC). Most branded computers have network card pre-installed. Network cards are 

of two types: Internal and External Network Cards. 

Internal Network Cards 

Motherboard has a slot for internal network card where it is to be inserted. Internal network cards are of two types in which the first 

type uses Peripheral Component Interconnect (PCI) connection, while the second type uses Industry Standard Architecture (ISA). 

Network cables are required to provide network access. 

 

 

External Network Cards 

External network cards are of two types: Wireless and USB based. Wireless network card needs to be inserted into the motherboard, 

however no network cable is required to connect to the network. 

 

 



 

 
 

46 
 

Universal Serial Bus (USB) 

USB card is easy to use and connects via USB port. Computers automatically detect USB card and can install the drivers required to 

support the USB network card automatically. 

 

 

Operating System 

 Operating System is the main software of the computer as everything will run on it in one form or other. 

 There are primarily three choices: Windows, Linux, Apple OS X. 

 Linux is free, however people generally do not use it for home purpose. 

 Apple OS X works only on Apple desktops. 

 Windows 7 is very popular among desktop users. 

 

 Most of the computers come pre-equipped with Windows 7 Starter edition. 

 Windows 8 is recently introduced and is available in the market. 

 Windows 7 and Windows 8 come in multiple versions from starter, home basic, home premium, professional, ultimate, and 

enterprise editions. 

 As the edition version increases, their features list and price increases. 

 Recommended − Windows 7 Home Premium. 

 

 

The Operating System is a program with the following features − 

 An operating system is a program that acts as an interface between the software and the computer hardware. 

 It is an integrated set of specialized programs used to manage overall resources and operations of the computer. 

 It is a specialized software that controls and monitors the execution of all other programs that reside in the computer, including 

application programs and other system software. 
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Objectives of Operating System 

The objectives of the operating system are − 

 To make the computer system convenient to use in an efficient manner. 

 To hide the details of the hardware resources from the users. 

 To provide users a convenient interface to use the computer system. 

 

 To act as an intermediary between the hardware and its users, making it easier for the users to access and use other resources. 

 To manage the resources of a computer system. 
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 To keep track of who is using which resource, granting resource requests, and mediating conflicting requests from different 

programs and users. 

 To provide efficient and fair sharing of resources among users and programs. Characteristics of Operating System 

Here is a list of some of the most prominent characteristic features of Operating Systems − 

 Memory Management − Keeps track of the primary memory, i.e. what part of it is in use by whom, what part is not in use, etc. 

and allocates the memory when a process or program requests it. 

 Processor Management − Allocates the processor (CPU) to a process and deallocates the processor when it is no longer 

required. 

 Device Management − Keeps track of all the devices. This is also called I/O controller that decides which process gets the 

device, when, and for how much time. 

 File Management − Allocates and de-allocates the resources and decides who gets the resources. 

 Security − Prevents unauthorized access to programs and data by means of passwords and other similar techniques. 

 Job Accounting − Keeps track of time and resources used by various jobs and/or users. 

 Control Over System Performance − Records delays between the request for a service and from the system. 

 Interaction with the Operators − Interaction may take place via the console of the computer in the form of instructions. The 

Operating System acknowledges the same, does the corresponding action, and informs the operation by a display screen. 

 Error-detecting Aids − Production of dumps, traces, error messages, and other debugging and error-detecting methods. 

 Coordination Between Other Software and Users − Coordination and assignment of compilers, interpreters, assemblers, and 

other software to the various users of the computer systems. 

COMPUTER LANGUAGES 

Over the years computer languages have evolved from machine languages to natural languages. The following is the summary of 

computer languages 

1940‘s -- Machine Languages 1950‘s -- Symbolic Languages 1960‘s -- 

High Level Languages 

Machine Language In the earliest days of computers, the only programming languages available were machine languages. Each 
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computer has its own machine language which is made of streams of 0‘s and 1‘s. The instructions in machine language must be in 

streams of 0‘s and 1‘s. This is also referred as binary digits. These are so named as the machine can directly understood the programs 

Advantages: 

1) High speed execution 2) The computer can understood instructions immediately 3) No translation is needed. 

Disadvantages: 

1) Machine dependent 2) Programming is very difficult 3) Difficult to understand 4) Difficult to write bug free programs 

5) Difficult to isolate an 

Symbolic Languages (or) Assembly Language 

In the early 1950‘s Admiral Grace Hopper, a mathematician and naval officer, developed the concept of a special computer program 

that would convert programs into machine language. These early programming languages simply mirrored the machine languages using 

symbols or mnemonics to represent the various language instructions. These languages were known as symbolic languages. Because a 

computer does not understand symbolic language it must be translated into the machine language. A special program called an 

Assembler translates symbolic code into the machine language. Hence they are called as Assembly language. 

Advantages: 1) Easy to understand and use 2) Easy to modify and isolate error 3) High efficiency 4) More control on hardware 

Disadvantages: 1) Machine Dependent Language 2) Requires translator 3) Difficult to learn and write programs 4) Slow development 

time 5) Less efficient 

High-Level Languages The symbolic languages greatly improved programming efficiency they still required programmers to 

concentrate on the hardware that they were using working with symbolic languages was also very tedious because each machine 

instruction had to be individually coded. The desire to improve programmer efficiency and to change the focus from the computer to 

the problems being solved led to the development of high-level languages. High-level languages are portable to many different computer 

allowing the programmer to concentrate on the application problem at hand rather than the intricacies of the computer 

Advantages: 1) Easy to write and understand 2) Easy to isolate an error 3) Machine independent language 4) Easy to maintain 5) Better 

readability 6) Low Development cost 7) Easier to document 8) Portable 

Disadvantages: 1) Needs translator 2) Requires high execution time 3) Poor control on hardware 

4) Less efficient 

Language Translators These are the programs which are used for converting the programs in one language into machine language 

instructions, so that they can be excuted by the computer. 
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1) Compiler: It is a program which is used to convert the high level language programs into machine language 

 

2) Assembler: It is a program which is used to convert the assembly level language programs into machine language 

3) Interpreter: It is a program; it takes one statement of a high level language program, translates it into machine language instruction 

and then immediately executes the resulting machine language instruction and so on. 

 

 

Comparison between a Compiler and Interpreter 

 

COMPILER INTERPRETER 

A Compiler is used to compile an entire 

program and an executable program is 

generated through the object program 

An interpreter is used to translate each line of 

the program code immediately as it is entered 

The executable program is stored in a disk for 

future use or to run it in another computer 
The executable program is generated in RAM 

and the interpreter is required for each run of 

the program 

The compiled programs run faster The Interpreted programs run slower 

Most of the Languages use compiler A very few languages use interpreters. 

 

Installing Hardware Driver 

 

If no driver update is found and you know there is a new version, then you'll need to manually download the latest driver from your 

manufacturer support website and follow their instructions. 

 

In the case, there are no instructions, and you got a .exe or .zip file with the driver, then double-click the .exe self- extracting 

package or use this guide to extract the content of the .zip compressed file, and then do the following: 

 

1. Open Start. 

2. Search for Device Manager, click the top result to open the experience. 

3. Expand the category with the hardware you want to update. 

https://www.windowscentral.com/how-zip-and-unzip-files-windows-10
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4. Right-click the device, and select Update Driver. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Click the Browse my computer for driver software option. 
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6. Click the Browse button. 

7. Browse and select the main folder with the content you have extracted earlier. 

8. Click OK. 

9. Check the Include subfolders to allow the wizard to find the correct .inf file with the instructions to update the driver. 
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10. Click the Next button. 

 

After completing the steps, the newer version of the driver will install on your computer for the device to address issues, introduce 

new functionalities, or add support for your version of Windows 10. 

 

Usually, you would use this method when updating drivers for older hardware or printers. 

 

How to verify driver has updated successfully 
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If you want to make sure you're using the most up-to-day version of the driver, you can check the driver version and date using the 

following steps: 

 

1. Open Start. 

2. Search for Device Manager, click the top result to open the experience. 

3. Expand the category with the hardware you updated. 

4. Right-click the device, and select Properties. 
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5.  

6. Click on the Driver tab. 
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In the "Driver" tab, note the "Driver Date" and "Driver Version" information. If these details match the information provided by 

the manufacturer, then you're running the latest version. 

 

Alternatively, you can check this information before updating the device driver, and if the date and version information increases, 

then you've successfully updated the hardware driver. 
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Wrapping things up 

 

Although Windows 10 does a good job automatically configuring new hardware and peripherals if you're experiencing problems 

you may need to update a driver manually. 

 

Just remember that if you're using a branded laptop, tablet, or desktop, it's best to first download the driver update from your PC 

manufacturer support website. Then if the update doesn't fix the issue, you should try getting the latest driver from the hardware part 

manufacturer website. 

 

Installing software on your Windows PC 

 

 

Your computer allows you to do some really amazing things. Digital photo editing, sophisticated computer gaming, video 

streaming—all of these things are possible because of different types of software. Developers are always creating new software 

applications, which allow you to do even more with your computer. 

 

Installing from a CD-ROM 

 

 

From the mid-1990s through the late 2000s, the most common way to get new software was to purchase a CD-ROM. You could then 

insert the disc, and the computer would walk you through through the installation. 

 

Now, almost all software has moved away from this model. Many new computers no longer include a CD-ROM for this reason. 

However, if you do need to install software from a CD-ROM, simply insert the disc into your computer, then follow the instructions. 

 

Installing software from the Web 
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Today, the most common way to get new software is to download it from the Internet. Applications like Microsoft Office and Adobe 

Photoshop can now be purchased and downloaded right to your computer. You can also install free software this way. For example, if 

you wanted to install the Google Chrome web browser, you can visit this page and click the Download button. 

 

The installation file will be saved to your computer in .exe format. Pronounced dot e-x-e, this is the standard extension for 

installation files on Windows computers. You can follow the steps below to install an application from an .exe file. 

 

1. Locate and download an .exe file. 

 

https://www.google.com/chrome/browser
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2. Locate and double-click the .exe file. (It will usually be in your Downloadsfolder.) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. A dialog box will appear. Follow the instructions to install the software. 
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4. The software will be installed. You can now open the application from the Start menu (Windows 7) or the Start Screen 

(Windows 8). 
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QUESTIONS 

Part-A 

1. What is a Computer? 

2. List some applications of a Computer. 

3. Draw the block diagram of a computer. 

4. What is MICR? Where is it used? 

5. Discuss the importance of Cache Memory. 

6. What are the different types of ROM 

7. What is Bootstrap? 

8. List out the advantages of Laser Printer over Dot matrix Printer. 

9. Differentiate Impact and Non-Impact Printer. 

10. List out the components of a Motherboard. 

11. Discuss the Features of a Motherboard. 

12. Define Nibble, Byte 

13. What is a Port? Give the different types of Port available in a Computer. 

14. Give the differences between Application Software and System Software  

 

! “ 
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Part-B 

1. Explain the Characteristics of Computers? 

2. Discuss in detail the applications of Computers in Various Fields? 

3. Write a detailed note on the Input, Output and Processing units of a Computer? 

4. Discuss about the Evolution and different Generation of Computers. 

5. Distinguish 

a) RAM and ROM. 

b) Hardware and Software 

6. What are the points to be remembered when assembling a personal Computer? 

7. Explain in Detail about Hard Disk Partitioning? 

8. What is an Operating System? Explain its Characteristics. 
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UNIT 2 

WORD PROCESSOR 

A word processor is a type of software application used for composing, editing, formatting and printing documents. 

Word processors have a variety of uses and applications within the business environment, at home and in educational 

contexts. 

 

Microsoft Office Word 2010 allows you to create and edit personal and business documents, such as 

letters, reports, invoices, emails and books. By default, documents saved in Word 2010 are saved with the 

.docx extension. Microsoft Word can be used for the following purposes − 

 To create business documents having various graphics including pictures, charts, and diagrams. 

 To store and reuse readymade content and formatted elements such as cover pages and sidebars. 

 To create letters and letterheads for personal and business purpose. 

 To design different documents such as resumes or invitation cards etc. 

 To create a range of correspondence from a simple office memo to legal copies and reference documents. 

Let us understand the various important parts of this window.. 
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 File Tab 

 The File tab replaces the Office button from Word 2007. You can click it to check the Backstage view. This is where you come when you need to 

open or save files, create new documents, print a document, and do other file-related operations. 

 

Quick Access Toolbar 
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This you will find just above the File tab. This is a convenient resting place for the mostfrequently used commands in Word. You can customize this 

toolbar based on your comfort. 

 

Ribbon 

 

 
Ribbon contains commands organized in three components − 

 

 Tabs − These appear across the top of the Ribbon and contain groups of related commands. Home, Insert, Page Layout are examples of ribbon 

tabs. 

 Groups − They organize related commands; each group name appears below the group on the Ribbon. For example, group of commands related to 

fonts or group of commands related to alignment, etc. 

 Commands − Commands appear within each group as mentioned above. 

 

Title bar 

This lies in the middle and at the top of the window. Title bar shows the program and document titles. 

 

Rulers 

Word has two rulers - a horizontal ruler and a vertical ruler. The horizontal ruler appears just beneath the Ribbon and is used to set margins and tab stops. 

The vertical ruler appears on the left edge of the Word window and is used to gauge the vertical position of elements on the page. 

 

Help 

The Help Icon can be used to get word related help anytime you like. This provides nice tutorial on various subjects related to word. 

 

Zoom Control 
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Zoom control lets you zoom in for a closer look at your text. The zoom control consists of a slider that you can slide left or right to zoom in or out; you 

can click the + buttons to increase or decrease the zoom factor. 

 

View Buttons 

The group of five buttons located to the left of the Zoom control, near the bottom of the screen, lets you switch through the Word's various document 

views. 

 Print Layout view − This displays pages exactly as they will appear when printed. 

 Full Screen Reading view − This gives a full screen view of the document. 

 Web Layout view − This shows how a document appears when viewed by a Web browser, such as Internet Explorer. 

 Outline view − This lets you work with outlines established using Word’s standard heading styles. 

 Draft view − This formats text as it appears on the printed page with a few exceptions. For example, headers and footers aren't shown. Most 

people prefer this mode. 

 

Document Area 

This is the area where you type. The flashing vertical bar is called the insertion point and it represents the location where text will appear when you type. 

 

Status Bar 

 

This displays the document information as well as the insertion point location. From left to right, this bar contains the total number of pages and words in 

the document, language, etc. 

You can configure the status bar by right-clicking anywhere on it and by selecting or deselecting options from the provided list. 

 

Dialog Box Launcher 

This appears as very small arrow in the lower-right corner of many groups on the Ribbon. Clicking this button opens a dialog box or task pane that provides 

more options about the group. 

The first column of the backstage view will have following options − 
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S.N

o 

Option & 

Description 

 

 

1 

Save 

 

If an existing document is opened, it will be saved as is, 

otherwise it will display a dialogue box asking for the 

document name. 

 

 

2 

Save As 

 

A dialogue box will be displayed asking for document name 

and document type, by default it will save in word 2010 

format with extension .docx. 

 

 

3 

Open 

 

This option is used to open an existing word document. 

 

 

4 

Close 

 

This option is used to close an open document. 

 

 

5 

Info 

 

This option displays information about the opened 

document. 

 

 

6 

Recent 

 

This option lists down all the recently opened documents 
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7 

New 

 

This option is used to open a new document. 

 

 

8 

Print 

 

This option is used to print an open document. 

 

 

9 

Save & Send 

 

This option will save an open document and will display 

options to send the document using email, etc. 
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10 

Help 

 

This option is used to get the required help about Word 

2010. 

 

 

11 

Options 

 

This option is used to set various option related to Word 

2010. 

 

 

12 

Exit 

 

Use this option to close the document and exit. 
TO ENTER THE TEXT 

 



 

 
 

71 
 

In this chapter, let us discuss how to enter text with Microsoft Word 2010. Let us see how easy it is to enter text in a Word document. We assume you 

know that when you start Word, it displays a new document by default as shown below − 

Document area is the area where you type your text. The flashing vertical bar is called the insertion point and it represents the location where the text will 

appear when you type. keep the cursor at the text insertion point and start typing the text. We typed only two words "Hello Word" as shown below. The 
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text appears to the left of the insertion point as you type − 

 
The following are the two important points that will help you while typing − 

 You do not need to press Enter to start a new line. As the insertion point reaches the end of the line, Word automatically starts a new one. 

You will need to press Enter, to add a new paragraph. 
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 When you want to add more than one space between words, use the Tab key instead of the spacebar. This way you can properly align text by using 

the proportional fonts. 

2. ALIGNMENTS 

 

Left-Aligned Text 

A paragraph's text is left aligned when it is aligned evenly along the left margin. Here is a simple procedure to make a paragraph text left-aligned. 

Step 1 − Click anywhere on the paragraph you want to align and click the Align Text Left button available on the Home tab or  

simply press the Ctrl + L keys. 
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Center Aligned Text 

A paragraph's text will be said center aligned if it is in the center of the left and right margins. Here is a simple procedure to make 

 a paragraph text center aligned. 

Step 1 − Click anywhere on the paragraph you want to align and click the Center button available on the Home tab or simply press 

 the Ctrl + E keys. 
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Right-Aligned Text 

A paragraph's text is right-aligned when it is aligned evenly along the right margin. Here is a simple procedure to make a paragraph text right-aligned. 

Step 1 − Click anywhere on the paragraph you want to align and click the Align Text Right button available on the Home tab or simply press the Ctrl + 

R keys. 
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Justified Text 

A paragraph's text is justified when it is aligned evenly along both the left and the right margins. Following is a simple  

procedure to make a paragraph text justified. 

Step 1 − Click anywhere on the paragraph you want to align and click the Justify button available on the Home tab or simply 

 press the Ctrl + J keys. 
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When you click the Justify button, it displays four options, justify, justify low, justify high and justify medium. You need to select only the justify 

option. The difference between these options is that low justify creates little space between two words, medium creates a more space than low justify and 

high creates maximum space between two words to justify the text. 

In this chapter, we will discuss the how to indent paragraphs in Word 2010. As you know the margin settings determine the blank space that appears on 

each side of a paragraph. You can indent paragraphs in your document from the left margin, the right margin, or both the margins. This chapter will teach 

you how to indent your paragraphs with or without the first line of the paragraphs. 

3. FORMATS 
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Copy and Apply of text formatting works for various text attributes; for example, text fonts, text colors, margins, headings, etc. 

 

Copy and Apply Text Formatting 

The following steps will help you understand how to copy and apply text formatting from one portion of text in your document to 

 another portion of text in your document. 

Step 1 − Select the portion of text containing the formatting that you want to copy. I have selected a text which has bold and underlined  

font as shown below. 
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Step 2 − click the Home tab and click the Format Painter button to copy the format of the selected text. As soon as you click the  

format painter button, the mouse pointer changes to a paint brush when you move the mouse over your document. 

Step 3 − Now you are ready to apply the copied text format to any of the selected text. So select a text using mouse where you want 

 to apply the copied text format. While selecting a portion of text, you have to make sure that your mouse pointer is still in paint brush  

shape. After selecting the text, just release the right-click button of the mouse and you will see that newly selected text is changed to the 

 format used for the original selection. You can click anywhere outside the selection to continue working on your document for further editing. 
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Copy and Apply Text Formatting multiple times 

Step 1 − If you are intended to apply formatting at multiple places, then you will have to double-click the Format Painter  

button while copying the text format. Later on, you just keep selecting the text where you want to apply the text formatting. 

Step 2 − When you are done with applying formatting at all the places, click Format Painter to come out of the format  

applying operation. 
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4. TABLES 

 

Createa Table 

The following steps will help you understand how to create a table in a Word document. 

 

Step 1 − Click the Insert tab followed by the Table button. This will display a simple grid as shown below. When you move your mouse  

over the grid cells, it makes a table in the table that appears in the document. You can make your table having the desired number of rows  

and columns. 
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Step 2 − Click the square representing the lower-right corner of your table, which will create an actual table in your document and 

 Word goes in the table design mode. The table design mode has many options to work with as shown below. 
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Step 3 − This is an optional step that can be worked out if you want to have a fancy table. Click the Table Styles button  

to display a gallery of table styles. When you move your mouse over any of the styles, it shows real time preview of your actual table. 

Step 4 − To select any of the styles, just click the built-in table style and you will see that the selected style has been applied on your table
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Delete a Table 

Following are the simple steps to delete an existing table from a word document. 

 

Step 1 − Click anywhere in the table you want to delete. 

 

Step 2 − Click the Layout tab, and click the Delete Table option under the Delete Table Button to delete the complete table  

from the document along with its content. 
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In this chapter, we will discuss how to work with rows and columns in Word 2010. As discussed in the previous chapter, a table is  

a structure of vertical columns and horizontal rows with a cell at every intersection. A Word table can contain as many as 63  

columns but the number of rows is unlimited. This chapter will teach you how to add and delete rows and columns in a table. 

 

Add a Row 

Following are the simple steps to add rows in a table of a word document. 
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Step 1 − Click a row where you want to add an additional row and then click the Layout tab; it will show the  

          following screen. 
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Step 2 − Now use the Row & Column group of buttons to add any row below or above to the selected row. If you click the  

Insert Below button, it will add a row just below the selected row as follows. 

If you click the Insert Above button, it will add a row just above the selected row. 
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Deletea Row 

The following steps will help you delete rows from a table of a Word document. 

 

Step 1 − Click a row which you want to delete from the table and then click the Layout tab; it will show the following screen. 

 

Step 2 − Click the Layout tab, and then click the Delete Rows option under the Delete Table Button to delete the selected row. 
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Add a Column 

The following steps will help you add columns in a table of a Word document. 
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Step 1 − Click a column where you want to add an additional column and then click the Layout tab; it will show  

the following screen. 

Step 2 − Now use the Row & Column group of buttons to add any column to the left or right of the selected column. If you click the Insert Left 

button, it will add a column just left to the selected column as follows. 
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If you click the Insert Right button, it will add a column just next to the selected column. 

 

Delete a Column 

Following are the simple steps to delete columns from a table of a word document. 

 

Step 1 − Click a column which you want to delete from the table and then click the Layout tab; it will show the following screen. 
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Step 2 − Click the Layout tab, and click the Delete Column option under the Delete Table Button to delete the selected column. 
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In this chapter, we will discuss how to move a table in Word 2010. Microsoft Word allows to move a table from one location to 

another location along with its content. This chapter will give you simple steps to move a table within the same document, though you can move a table 

from one document to another document using the cut and paste operation. 

 

Move a Table 

The following steps will help you move a table within the same Word document. 
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Step 1 − Bring your mouse pointer over the table which you want to move from one location to another location. As soon as you 

 bring your mouse pointer inside the table, a small Cross Icon will appear at the top-left corner of the table as shown below. 

Step 2 − Click over the small Cross Icon which will select the whole table. Once the table is selected, use the Cut button or 

 simply press the Ctrl + Xkeys to cut the table from its original location. 

Step 3 − Bring your insertion point at the location where you want to move the table and use Paste button or simply press Ctrl 

+ V keys to paste the table at the new location. 
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In this chapter, we will discuss how to resize a table in Word 2010. Microsoft Word allows to resize a table to make it smaller  

and bigger as per your requirement. 

 

Resize a Table 

The following steps will help you resize a table available in a Word document. 

 

Step 1 − Bring your mouse pointer over the table which you want to resize. As soon as you bring your mouse pointer inside the table,  

a small Cross Iconwill appear at the top-left corner and a small Resize Icon will appear at the bottom-right corner of the table as shown below. 
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Step 2 − Bring the mouse pointer over the Resize Icon till it changes to a diagonal doublesided arrow and this is the time when you 

 need to press the left mouse button and keep holding the button while resizing the table. Drag the table up to make it shorter or  

down to make it larger. You can drag the table diagonally to simultaneously change both the width and the height of the table. 
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In this chapter, we will discuss how to merge table cells in Word 2010. Microsoft Word allows the merging of two or more cells to  

create one large cell. You will frequently need to merge columns of the top row to create the title of the table. You can merge cells  

either row-wise or column-wise, rather you cannot merge cells diagonally. This chapter will teach you how to merge multiple rows 

 or columns. 
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Merging Cells 

The following steps will help you merge table cells in a Word document. 

 

Step 1 − Bring your mouse pointer position inside the first cell that you want to merge. Now press the Shift key and click the  

cells around the cell which you want to merge into the first cell. This will highlight the cells which you click and they will be 

 ready to be merged. 

 

 
Step 2 − Now click the Layout tab and then click the Merge Cells button which will merge all the selected cells. 
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After merging the cells, all the content of the cells will be scrambled which you can fix later as you like. For example, you can  

convert the merged cells text into title or some other description. For example, let us have center-aligned and bigger font text as  

follows on top of the table. 

 

Split a Table 

 

Following are the simple steps to split a table into two tables in a Word document. 

 

Step 1 − Bring your mouse pointer position anywhere in the row that should appear as the first row of the new table. 
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Step 2 − Now click the Layout tab and then click the Split Table button which will split the table into two tables and 

 the selected row will become the first row of the lower table. 
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After splitting the table into two tables, you can further divide it into two parts and you can continue dividing the Word tables  

as long as a table has more than one row. 

 

 

 

In this chapter, we will discuss how to split table cells in Word 2010. Microsoft Word allows splitting a cell into multiple cells.  

We will understand how to split a cell into multiple smaller sub-cells. 

 

Split a Cell 

The following steps will help you split a cell into two sub-cells of a table available in word document. 
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Step 1 − Bring your mouse pointer position inside the cell that has to be divided into multiple cells. 
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Step 2 − Now click the Layout tab and then click the Split Cells button; this will display a dialog box asking for the number of 

 rows and columns to be created from the selected cell. 

Step 3 − Select the desired number of rows and columns that have to go into the resultant cell and finally click the OK button 

 to apply the result. 
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You can divide a cell into multiple cells either row-wise or column-wise or both. 

 

Adda Formula 

Following are the simple steps to add formula in a table cell available in Word document. 

 

Step 1 − Consider the following table with the total number of rows. Click in a cell that should contain the sum of the rows. 
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Step 2 − Now click the Layout tab and then click the Formula button; this will display a Formula Dialog Box which will 

 suggest a default formula, which is =SUM(LEFT) in our case. You can select a number format using Number Format List 

 Box to display the result or you can change the formula using the Formula List Box. 

Step 3 − Now click OK to apply the formula and you will see that the left cells have been added and the sum has been put in 

 the total cell where we wanted to have it. You can repeat the procedure to have the sum of other two rows as well. 
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Cell Formulae 

The Formula dialog box provides the following important functions to be used as formula in a cell. 

 

S.N

o 

Formula & 

Description 

 

1 
AVERAGE( ) 

 

The average of a list of cells 

 

 

2 

COUNT( ) 

 

The number of items in a list of cells 

 

 

3 

MAX( ) 

 

The largest value in a list of cells 

 

 

4 

MIN( ) 

 

The smallest value in a list of cells 

 

 

5 

PRODUCT( ) 

 

The multiplication of a list of cells 

 

 

6 

SUM( ) 

 

The sum of a list of cells 

6 LEFT, referring to all cells in the row to the left of the 

current cell 

7 RIGHT, referring to all cells in the row to the right of the 

current cell 

 

Add Borders to Table 
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The following steps will help you add borders in a table cell available in Word document. 

 

Step 1 − Select the table to which you want to add border. To select a table, click over the table anywhere which will make the  

Cross icon visible at the top-left corner of the table. Click this cross icon to select the table. 

Step 2 − Click the Border button to display a list of options to put a border around the selected table. You can select any of the  

option available by simply clicking over it. 



 

 
 

111 
 

 
Step 3 − Try to add and remove different borders like left, right, top or bottom by selecting different options from the border options. 
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Step 4 − You can apply border to any of the selected row or column. You can try it yourself. 

 

Step 5 − To delete the existing border, simply select the No Border option from the border options. 

 

Using Border Options 

You can add borders of your choice to word table by following the simple steps given below. 

 

Step 1 − Click the Border button to display a list of options to put a border. Select the Border and Shading option available at 

 the bottom of the list of options as shown in the above screenshot. This will display a Border and Shading dialog box. This 

 dialog box can be used to set borders and shading around a selected table. 
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Step 2 − Click the Border tab; this will display a list of border settings, styles and options whether this border should be  

applied to the table or text or paragraph. 

Step 3 − You can use the Preview section to disable or enable left, right, top or bottom borders of the selected table or row or column. 

 Follow the given instructions in the preview section itself to design the border you like. 

Step 4 − You can customize your border by setting its color, width by using different width thickness available under the style section. 
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Add Shades To Table 

The following steps will help you add shades on a selected table or its rows or columns. 

 

Step 1 − Select a row or column where you want to apply a shade of your choice. 
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Step 2 − Click the Border button to display a list of options to put a border. Select the Border and Shading option available  

at the bottom of the list of options. This will display a Border and Shading dialog box. This dialog box can be used to set borders 

 and shading around selected row(s) or column(s). 

Step 2 − Click the Shading tab which will display options to select fill, colorand style and whether this border should 

 be applied to cell or table or selected portion of text. 

Step 3 − You can use the Preview section to have an idea about the expected result. Once you are done, click the OK button to 

 apply the result. 
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5. MAIL MERGE 

 

In this chapter, we will discuss how to email documents using Word 2010. Microsoft Word can be used to send a Word 

 document in an email as an attachment directly at the given email address without opening your email program. This chapter 

 will teach you simple ways of sending email in a variety of formats, including a Word document file (DOC) attachment or a 

 PDF, among others. 

 

Mailing Documents 

Following are the simple steps to send a word document as an attachment at the given email address. 

 

Step 1 − Open the document you want to send using e-mail as an attachment. 

 

Step 2 − Click the File tab and then click the Save & Send option from the left most column; this will display a number of  

options to Save & Send, you will have to select the Send using Email option available in the middle column. 
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Step 3 − The third column will have various options to send email which allows you to send your document as an attachment in  

DOC format or you can send your Word document in a PDF format. Click a method to send the document. I'm going to send my  

document in PDF format. 

When you click the Send as PDF option, it displays the following screen where you can type the email address to which you want to  

send your document, email subject and other additional messages as well. To send email to multiple recipients, separate each 

 e-mail address with a semicolon (;) and a space. 
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6. SPELL CHECK AND GRAMMER 

 

 A red underline beneath spelling errors. 

 A green underline beneath grammar errors. 

 A blue line under correctly spelled but misused words. 

Check Spelling and Grammarusing Review tab 

Here is the simple procedure to find out the spelling mistakes and fix them − 

 

Step 1 − Click the Review tab and then click the Spelling & Grammar button. 
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Step 2 − A Spelling and Grammar dialog box will appear and will display the wrong spellings or errors in grammar. You will also get suggestions to 

correct as shown below − 
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Now you have following options to fix the spelling mistakes − 

 

 Ignore − If you are willing to ignore a word, then click this button and Word ignores the word throughout the document. 

 Ignore All − Like Ignore, but this ignores all occurrences of the same misspelling, not just once but throughout the document. 

 Add to Dictionary − Choose Add to Dictionary to add the word to the Word spelling dictionary. 

 Change − This will change the wrong word using the suggested correct word. 
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 Change All − Like Change, but this changes all occurrences of the same misspelling, not just once but throughout the document. 

 AutoCorrect − If you select a suggestion, Word creates an AutoCorrect entry that automatically corrects this spelling error from now on. 

 

Following are the different options in case you have grammatical mistake − 

 Next Sentence − You can click Next Sentence to direct the grammar checker to skip ahead to the next sentence. 

 Explain − The grammar checker displays a description of the rule that caused the sentence to be flagged as a possible error. 

 Options − This will open the Word Options dialog box to allow you to change the behavior of the grammar checker or spelling options. 

 

 Undo − This will undo the last grammar changed. 

Step 3 − Select one of the given suggestions you want to use and click the Change option to fix the spelling or grammar mistake and repeat the step 

to fix all the spelling or grammar mistake. 

Step 4 − Word displays a dialog box when it finishes checking for spelling and grammar mistakes, finally Click OK. 
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Check Spelling and Grammarusing Right Click 

If you will right-click the mouse button over a misspelled word, then it will show you the correct suggestions and the above  

mentioned options to fix the spelling or grammar mistake. Try it yourself. 

In this chapter, we will discuss auto correction in Word 2010. The AutoCorrect feature automatically corrects common  
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typographical errors when you make them. Let us learn how to use the auto correction option available in Microsoft Word 2010 

 to correct the spelling automatically as you type the words in your documents. 

 

Setting AutoCorrect 

The following steps will help to enable the AutoCorrect feature in Microsoft Word. 

 

Step 1 − Click the File tab, click Options, and then click the Proofing option available in the left most column, it will display 

 the Word Options dialog box. 
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Step   2 −  Click  the AutoCorrect   Options button  which  will  display  the AutoCorrect dialog  box  and  then  click   

  the AutoCorrect tab. Now you have to make sure all the options are enabled, especially the Replace Text as you type option.  

It is also recommended to be careful when you turn off an option. 
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Step 3 − Select from among the following options, depending on your preferences. 

 

S.N

o 

Option and 

Description 
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1 

Show AutoCorrect Options Buttons 

 

This option will be used to display a small blue button or bar 

beneath text that was automatically corrected. Click this 

button to see a menu, where you can undo the correction or set 

AutoCorrect options. 

 

 

2 

Correct TWo Initial CApitals 

 

This option changes the second letter in a pair of capital letters 

to lowercase. 

 

 

3 

Capitalize first letter of sentences 

 

This option capitalizes the first letter following the end of a 

sentence. 
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4 

Capitalize first letter of table cells 

 

This option will be used to capitalize the first letter of a word 

in a table cell. 

 

 

5 

Capitalize names of days 

 

This option will be used to capitalize the names of the days 

of the week. 

 

 

6 

Correct accidental usage of cAPS LOCK key 

 

This option will be used to correct capitalization errors that 

occur when you type with the CAPS LOCK key depressed 

and turns off this key. 

 

 

7 

Replace text as you type 

 

This option replaces typographical errors with the correct 

words as shown in the list beneath it. 

 

 

8 

Automatically use suggestions from the spelling checker 

 

This option tells Word to replace spelling errors with words 

from the dictionary as you type. 

Although Word comes preconfigured with hundreds of AutoCorrect entries, you can also manually add entries using the following 

 dialog box and use the Replace and With text boxes to add more entries. I added an entry for Markiting which should be replaced  

with Marketing. You can use the Addbutton to add multiple entries. 

Step 4 − Click OK to close the AutoCorrect Options dialog box and again click OK to close the Word Options dialog box.  

Now try to  type Markitingand  as  soon  as  you  type  this  word,  Microsoft  Word  autocorrects  it  with  the  correct  word  

Marketing word. 
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MACROS 

 

In Word, you can automate frequently used tasks by creating and running macros. A macro is a series of commands and instructions 

 that you group together as a single command to accomplish a task automatically. 
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To save time on tasks you do often, bundle the steps into a macro. First, you record the macro. Then you can run the macro by  

clicking a button on the Quick Access Toolbar or pressing a combination of keys. It depends on how you set it up. 

 

 

 

Record a macro with a button 

 

 

1. Click View > Macros > Record Macro. 

 
 

2. Type a name for the macro. 
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3. To use this macro in any new documents you make, be sure the Store macro in box says All Documents (Normal.dotm). 

 

4. To run your macro when you click a button, click Button. 

 

5. Click the new macro (it’s named something like Normal.NewMacros.<your macro name>), and click Add. 
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6. Click Modify. 

7. Choose a button image, type the name you want, and click OK twice. 
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8. Now it’s time to record the steps. Click the commands or press the keys for each step in the task. Word records your clicks and keystrokes. 

 

 

9. To stop recording, click View > Macros > Stop Recording. 

Note: Use the keyboard to select text while you’re recording your macro. Macros don’t record 

selections made with a mouse. 
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The button for your macro appears on the Quick Access Toolbar. 

 

To run the macro, click the button. 

To run a macro, click the button on the Quick Access Toolbar, press the keyboard shortcut, or you can run the macro from the Macros list. 

1. Click View > Macros > View Macros. 
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2. In the list under Macro name, click the macro you want to run. 

3. Click Run. 

To make a macro from one document available in all new documents, add it to the Normal.dotm template. 

1. Open the document that contains the macro. 

2. Click View > Macros > View Macros. 

 

3. Click Organizer. 
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QUESTIONS 

Part-A 

1. What is a Word Processor? State some applications 

2. What are the different View Buttons in Microsoft Word? 

3. “Justified Text”-Explain? 

4. What is the function of Format Painter? 

5. Give the steps for merging a cell in a table in MS-Word. 

6. State the different formulas used in MS-Word. 

7. What is Mail merge? 

8. Define a Macro. 

Part-B 

1. What are the steps for formatting a document and aligning a paragraph in MS Word? 

2. Write a note on Mail Merge and Macros. 

3. What are the Procedure to set Autocorrect in Spellcheck? 

4. Explain the steps to create a table, delete a table. Also explain the other necessary features of tables. 
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UNIT 3 

INTRODUCTION  

. Microsoft Excel is a spreadsheet tool capable of performing calculations, analyzing data and integrating 

information from different programs. 

The following basic window appears when you start the excel application. Let us now understand the various 

important parts of this window. 

 

File Tab 

You can click it to check the Backstage  view, where you come when you need to open or save files, create new 

sheets, print a sheet, and do other file-related operations. 

Quick Access Toolbar 

You will find this toolbar just above the File tab and its purpose is to provide a convenient resting place for the 
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Excel's most frequently used commands. You can customize this toolbar based on your comfort. 

Ribbon 

 

Ribbon contains commands organized in three components − 

• Tabs − They appear across the top of the Ribbon and contain groups of related commands. Home , Insert, 

Page Layout are the examples of ribbon tabs. 

• Groups – They organize related commands; each group name appears below the group on the Ribbon. For 

example, group of commands related to fonts or group of commands related to alignment etc. 

• Commands − Commands appear within each group as mentioned above. 

Title Bar 

This lies in the middle and at the top of the window. Title bar shows the program and the sheet titles. 

Help 

The Help Icon can be used to get excel related help anytime you like. This provides nice tutorial on various 

subjects related to excel. 

Zoom Control 

Zoom control lets you zoom in for a closer look at your text. The zoom control consists of a slider that you can 

slide left or right to zoom in or out. The + buttons can be clicked to increase or decrease the zoom factor. 

View Buttons 

The group of three buttons located to the left of the Zoom control, near the bottom of the screen, lets you switch 

among excel's various sheet views. 

• Normal Layout view − This displays the page in normal view. 

• Page Layout view − This displays pages exactly as they will appear when printed. This gives a full screen 

look of the document. 

• Page Break view − This shows a preview of where pages will break when printed. 

Sheet Area 

The area where you enter data. The flashing vertical bar is called the insertion point and it represents the location 

where text will appear when you type. 
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Row Bar 

Rows are numbered from 1 onwards and keeps on increasing as you keep entering data. Maximum limit is 

1,048,576 rows. 

Column Bar 

Columns are numbered from A onwards and keeps on increasing as you keep entering data. After Z, it will start 

the series of AA, AB and so on. Maximum limit is 16,384 columns. 

Status Bar 

This displays the sheet information as well as the insertion point location. From left to right, this bar can contain 

the total number of pages and words in the document, language etc. 

You can configure the status bar by right-clicking anywhere on it and by selecting or deselecting options from the 

provided list. 

Dialog Box Launcher 

This appears as a very small arrow in the lower-right corner of many groups on the Ribbon. Clicking this button 

opens a dialog box or task pane that provides more options about the group. 

The Backstage view has been introduced in Excel 2010 and acts as the central place for managing your sheets. 

The backstage view helps in creating new sheets, saving and opening sheets, printing and sharing sheets, and so 

on. 

Getting to the Backstage View is easy. Just click the File tab located in the upper-left corner of the Excel Ribbon. 

If you already do not have any opened sheet then you will see a window listing down all the recently opened sheets 

as follows − 
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If you already have an opened sheet then it will display a window showing the details about the opened sheet as 

shown below. Backstage view shows three columns when you select most of the available options in the first 

column. 
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First column of the backstage view will have the following options − 

S.No. Option & Description 

1 Save 

If an existing sheet is opened, it would be saved as is, otherwise it will display a 

dialogue box asking for the sheet name. 

2 Save As 

A dialogue box will be displayed asking for sheet name and sheet type. By default, 

it will save in sheet 2010 format with extension .xlsx. 

3 Open 

This option is used to open an existing excel sheet. 

4 Close 
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This option is used to close an opened sheet. 

5 Info 

This option displays the information about the opened sheet. 

6 Recent 

This option lists down all the recently opened sheets. 

7 New 

This option is used to open a new sheet. 

8 Print 

This option is used to print an opened sheet. 

9 Save & Send 

This option saves an opened sheet and displays options to send the sheet using 

email etc. 

10 Help 

You can use this option to get the required help about excel 2010. 

11 Options 

Use this option to set various option related to excel 2010. 

12 Exit 

Use this option to close the sheet and exit. 

Sheet Information 

When you click Info option available in the first column, it displays the following information in the second 

column of the backstage view − 
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• Compatibility Mode − If the sheet is not a native excel 2007/2010 sheet, a Convert button appears here, 

enabling you to easily update its format. Otherwise, this category does not appear. 

• Permissions − You can use this option to protect the excel sheet. You can set a password so that nobody 

can open your sheet, or you can lock the sheet so that nobody can edit your sheet. 

• Prepare for Sharing − This section highlights important information you should know about your sheet 

before you send it to others, such as a record of the edits you made as you developed the sheet. 

• Versions − If the sheet has been saved several times, you may be able to access previous versions of it from 

this section. 

Sheet Properties 

When you click Info option available in the first column, it displays various properties in the third column of the 

backstage view. These properties include sheet size, title, tags, categories etc. 

You can also edit various properties. Just try to click on the property value and if property is editable, then it will 

display a text box where you can add your text like title, tags, comments, Author. 

Exit Backstage View 

It is simple to exit from the Backstage View. Either click on the File tab or press the Esc button on the keyboard 

to go back to excel working mode. 

Entering values in excel sheet is a child’s play and this chapter shows how to enter values in an excel sheet. A new 

sheet is displayed by default when you open an excel sheet as shown in the below screen shot. 
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Sheet area is the place where you type your text. The flashing vertical bar is called the insertion point and it 

represents the location where text will appear when you type. When you click on a box then the box is highlighted. 

When you double click the box, the flashing vertical bar appears and you can start entering your data. 

So, just keep your mouse cursor at the text insertion point and start typing whatever text you would like to type. 

We have typed only two words "Hello Excel" as shown below. The text appears to the left of the insertion point 

as you type. 
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There are following three important points, which would help you while typing − 

• Press Tab to go to next column. 

• Press Enter to go to next row. 

• Press Alt + Enter to enter a new line in the same column. 

Saving New Sheet 

Once you are done with typing in your new excel sheet, it is time to save your sheet/workbook to avoid losing 

work you have done on an Excel sheet. Following are the steps to save an edited excel sheet − 

Step 1 − Click the File tab and select Save As option. 
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Step 2 − Select a folder where you would like to save the sheet, Enter file name, which you want to give to your 

sheet and Select a Save as type, by default it is .xlsx format.
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Step 3 − Finally, click on Save button and your sheet will be saved with the entered name in the selected folder. 

Saving New Changes 

There may be a situation when you open an existing sheet and edit it partially or completely, or even you would 

like to save the changes in between editing of the sheet. If you want to save this sheet with the same name, then 

you can use either of the following simple options − 

• Just press Ctrl + S keys to save the changes. 

• Optionally, you can click on the floppy icon available at the top left corner and just above the File tab. This 

option will also save the changes. 

• You can also use third method to save the changes, which is the Saveoption available just above the Save 

As option as shown in the above screen capture. 

If your sheet is new and it was never saved so far, then with either of the three options, word would display you a 

dialogue box to let you select a folder, and enter sheet name as explained in case of saving new sheet. 

4. CELL FORMATS 
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MS Excel Cell can hold different types of data like Numbers, Currency, Dates, etc. You can set the cell type in 

various ways as shown below − 

• Right Click on the cell » Format cells » Number. 

• Click on the Ribbon from the ribbon. 

 

Various Cell Formats 

Below are the various cell formats. 

• General − This is the default cell format of Cell. 

• Number − This displays cell as number with separator. 

• Currency − This displays cell as currency i.e. with currency sign. 

• Accounting − Similar to Currency, used for accounting purpose. 

• Date − Various date formats are available under this like 17-09-2013, 17th-Sep-2013, etc. 

• Time − Various Time formats are available under this, like 1.30PM, 13.30, etc. 

• Percentage − This displays cell as percentage with decimal places like 50.00%. 

• Fraction − This displays cell as fraction like 1/4, 1/2 etc. 

• Scientific − This displays cell as exponential like 5.6E+01. 
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• Text − This displays cell as normal text. 

• Special − Special formats of cell like Zip code, Phone Number. 

• Custom − You can use custom format by using this. 

 

6. PIVOT TABLES 

A pivot table is essentially a dynamic summary report generated from a database. The database can reside in a 

worksheet (in the form of a table) or in an external data file. A pivot table can help transform endless rows and 

columns of numbers into a meaningful presentation of the data. Pivot tables are very powerful tool for summarized 

analysis of the data. 

Pivot tables are available under Insert tab » PivotTable dropdown » PivotTable. 

Pivot Table Example 

Now, let us see Pivot table with the help of example. Suppose you have huge data of voters and you want to see 

the summarized data of voter Information per party, then you can use the Pivot table for it. Choose Insert tab » 

Pivot Table to insert pivot table. MS Excel selects the data of the table. You can select the pivot table location as 

existing sheet or new sheet. 
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This will generate the Pivot table pane as shown below. You have various options available in the Pivot table pane. 

You can select fields for the generated pivot table. 
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• Column labels − A field that has a column orientation in the pivot table. Each item in the field occupies a 

column. 

• Report Filter − You can set the filter for the report as year, then data gets filtered as per the year. 

• Row labels − A field that has a row orientation in the pivot table. Each item in the field occupies a row. 

• Values area − The cells in a pivot table that contain the summary data. Excel offers several ways to 

summarize the data (sum, average, count, and so on). 

After giving input fields to the pivot table, it generates the pivot table with the data as shown below. 
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Formulas in MS Excel 

Formulas are the Bread and butter of worksheet. Without formula, worksheet will be just simple tabular 

representation of data. A formula consists of special code, which is entered into a cell. It performs some 

calculations and returns a result, which is displayed in the cell. 

Formulas use a variety of operators and worksheet functions to work with values and text. The values and text 

used in formulas can be located in other cells, which makes changing data easy and gives worksheets their dynamic 

nature. For example, you can quickly change the data in a worksheet and formulas works. 

Elements of Formulas 

A formula can consist of any of these elements − 

• Mathematical operators, such as +(for addition) and *(for multiplication) 

Example − 

o =A1+A2 Adds the values in cells A1 and A2. 

• Values or text 

Example − 
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o =200*0.5 Multiplies 200 times 0.15. This formula uses only values, and it always returns the same 

result as 100. 

• Cell references (including named cells and ranges) 

Example − 

o =A1=C12 Compares cell A1 with cell C12. If the cells are identical, the formula returns TRUE; 

otherwise, it returns FALSE. 

• Worksheet functions (such as SUMor AVERAGE) 

Example − 

o =SUM(A1:A12) Adds the values in the range A1:A12. 

7. FORMULA 

For creating a formula you need to type in the Formula Bar. Formula begins with '=' sign. When building formulas 

manually, you can either  

type in the cell addresses or you can point to them in the worksheet. Using the Pointing method to supply the cell 

addresses for formulas is  

often easier and more powerful method of formula building. When you are using built-in functions, you click the 

cell or drag through the 

 cell range that you want to use when defining the function’s arguments in the Function Arguments dialog box. 

See the below screen shot. 
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As soon as you complete a formula entry, Excel calculates the result, which is then displayed inside the cell within 

the worksheet (the contents of the formula, however, continue to be visible on the Formula bar anytime the cell is 

active). If you make an error in the formula that prevents Excel from being able to calculate the formula at all, 

Excel displays an Alert dialog box suggesting how to fix the problem. 

Copying Formulas in MS Excel 

Copying formulas is one of the most common tasks that you do in a typical spreadsheet that relies primarily on 

formulas. When a formula uses cell references rather than constant values, Excel makes the task of copying an 

original formula to every place that requires a similar formula. 

Relative Cell Addresses 

MS Excel does it automatically adjusting the cell references in the original formula to suit the position of the copies 

that you make. It does this through a system known as relative cell addresses, where by the column references in 

the cell address in the formula change to suit their new column position and the row references change to suit their 

new row position. 

Let us see this with the help of example. Suppose we want the sum of all the rows at last, then we will write a 

formula for first column i.e. B. We want sum of the rows from 3 to 8 in the 9th row. 
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After writing formula in the 9th row, we can drag it to remaining columns and the formula gets copied. After 

dragging we can see the formula in the remaining columns as below. 

• column C : =SUM(C3:C8) 

• column D : =SUM(D3:D8) 

• column E : =SUM(E3:E8) 

• column F : =SUM(F3:F8) 

• column G : =SUM(G3:G8) 
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Cell References in Formulas 

Most formulas you create include references to cells or ranges. These references enable your formulas to work 

dynamically with the data contained in those cells or ranges. For example, if your formula refers to cell C2 and 

you change the value contained in C2, the formula result reflects new value automatically. If you didn’t use 

references in your formulas, you would need to edit the formulas themselves in order to change the values used in 

the formulas. 

When you use a cell (or range) reference in a formula, you can use three types of references − relative, absolute, 

and mixed references. 

Relative Cell References 

The row and column references can change when you copy the formula to another cell because the references are 

actually offsets from the current row and column. By default, Excel creates relative cell references in formulas. 
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Absolute Cell References 

The row and column references do not change when you copy the formula because the reference is to an actual 

cell address. An absolute reference uses two dollar signs in its address: one for the column letter and one for the 

row number (for example, $A$5).
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Mixed Cell References 

Both the row or column reference is relative and the other is absolute. Only one of the address parts is absolute 

(for example, $A5 or A$5). 



 

 
 

161 
 

 

Functions in Formula 

Many formulas you create use available worksheet functions. These functions enable you to greatly enhance the 

power of your formulas and perform calculations that are difficult if you use only the operators. For example, you 

can use the LOG or SIN function to calculate the Logarithm or Sin ratio. You can’t do this complicated calculation 

by using the mathematical operators alone. 

Using Functions 

When you type = sign and then type any alphabet you will see the searched functions as below. 
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Suppose you need to determine the largest value in a range. A formula can’t tell you the answer without using a 

function. We will use formula that uses the MAX function to return the largest value in the range B3:B8 

as =MAX(A1:D100). 
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Another example of functions. Suppose you want to find if the cell of month is greater than 1900 then we can give 

Bonus to Sales representative. The we can achieve it with writing formula with IF functions 

as =IF(B9>1900,"Yes","No") 
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Function Arguments 

In the above examples, you may have noticed that all the functions used parentheses. The information inside the 

parentheses is the list of arguments. 

Functions vary in how they use arguments. Depending on what it has to do, a function may use. 

• No arguments − Examples − Now(), Date(), etc. 

• One argument − UPPER(), LOWER(), etc. 

• A fixed number of arguments − IF(), MAX(), MIN(), AVERGAGE(), etc. 

• Infinite number of arguments 

• Optional arguments 

Built In Functions 

MS Excel has many built in functions, which we can use in our formula. To see all the functions by category, 

choose Formulas Tab » Insert Function. Then Insert function Dialog appears from which we can choose the 

function. 
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Functions by Categories 

Let us see some of the built in functions in MS Excel. 

• Text Functions 

o LOWER − Converts all characters in a supplied text string to lower case 

o UPPER − Converts all characters in a supplied text string to upper case 

o TRIM − Removes duplicate spaces, and spaces at the start and end of a text string 

o CONCATENATE − Joins together two or more text strings. 

o LEFT − Returns a specified number of characters from the start of a supplied text string. 

o MID − Returns a specified number of characters from the middle of a supplied text string 

o RIGHT − Returns a specified number of characters from the end of a supplied text string. 

o LEN − Returns the length of a supplied text string 

o FIND − Returns the position of a supplied character or text string from within a supplied text string 

(case-sensitive). 

• Date & Time 
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o DATE − Returns a date, from a user-supplied year, month and day. 

o TIME − Returns a time, from a user-supplied hour, minute and second. 

o DATEVALUE − Converts a text string showing a date, to an integer that represents the date in 

Excel's date-time code. 

o TIMEVALUE − Converts a text string showing a time, to a decimal that represents the time in 

Excel. 

o NOW − Returns the current date & time. 

o TODAY − Returns today's date. 

• Statistical 

o MAX − Returns the largest value from a list of supplied numbers. 

o MIN − Returns the smallest value from a list of supplied numbers. 

o AVERAGE − Returns the Average of a list of supplied numbers. 

o COUNT − Returns the number of numerical values in a supplied set of cells or values. 

o COUNTIF − Returns the number of cells (of a supplied range), that satisfies a given criteria. 

o SUM − Returns the sum of a supplied list of numbers 

• Logical 

o AND − Tests a number of user-defined conditions and returns TRUE if ALL of the conditions 

evaluate to TRUE, or FALSE otherwise 

o OR − Tests a number of user-defined conditions and returns TRUE if ANY of the conditions 

evaluate to TRUE, or FALSE otherwise. 

o NOT − Returns a logical value that is the opposite of a user supplied logical value or expression i.e. 

returns FALSE if the supplied argument is TRUE and returns TRUE if the supplied argument is 

FAL 

• Math & Trig 

o ABS − Returns the absolute value (i.e. the modulus) of a supplied number. 

o SIGN − Returns the sign (+1, -1 or 0) of a supplied number. 

o SQRT − Returns the positive square root of a given number. 
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o MOD − Returns the remainder from a division between two supplied numbers. 

 

8. CONDITIONAL FORMATTING 

MS Excel 2010 Conditional Formatting feature enables you to format a range of values so that the values outside 

certain limits, are automatically formatted. 

Choose Home Tab » Style group » Conditional Formatting dropdown. 

Various Conditional Formatting Options 

• Highlight Cells Rules − It opens a continuation menu with various options for defining the formatting rules 

that highlight the cells in the cell selection that contain certain values, text, or dates, or that have values 

greater or less than a particular value, or that fall within a certain ranges of values. 

Suppose you want to find cell with Amount 0 and Mark them as red.Choose Range of cell » Home Tab » 

Conditional Formatting DropDown » Highlight Cell Rules » Equal To. 

 

After Clicking ok, the cells with value zero are marked as red. 
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• Top/Bottom Rules − It opens a continuation menu with various options for defining the formatting rules 

that highlight the top and bottom values, percentages, and above and below average values in the cell 

selection. 

Suppose you want to highlight the top 10% rows you can do this with these Top/Bottom rules. 
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• Data Bars − It opens a palette with different color data bars that you can apply to the cell selection to 

indicate their values relative to each other by clicking the data bar thumbnail. 

With this conditional Formatting data Bars will appear in each cell. 
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• Color Scales − It opens a palette with different three- and two-colored scales that you can apply to the cell 

selection to indicate their values relative to each other by clicking the color scale thumbnail. 

See the below screenshot with Color Scales, conditional formatting applied. 

 

• Icon Sets − It opens a palette with different sets of icons that you can apply to the cell selection to indicate 

their values relative to each other by clicking the icon set. 

See the below screenshot with Icon Sets conditional formatting applied. 
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• New Rule − It opens the New Formatting Rule dialog box, where you define a custom conditional 

formatting rule to apply to the cell selection. 

• Clear Rules − It opens a continuation menu, where you can remove the conditional formatting rules for the 

cell selection by clicking the Selected Cells option, for the entire worksheet by clicking the Entire Sheet 

option, or for just the current data table by clicking the This Table option. 

• Manage Rules − It opens the Conditional Formatting Rules Manager dialog box, where you edit and delete 

particular rules as well as adjust their rule precedence by moving them up or down in the Rules list box. 

9. SORT 

Sorting data in MS Excel rearranges the rows based on the contents of a particular column. You may want to sort 

a table to put names in alphabetical order. Or, maybe you want to sort data by Amount from smallest to largest or 

largest to smallest. 

To Sort the data follow the steps mentioned below. 

• Select the Column by which you want to sort data. 

• Choose Data Tab » Sort Below dialog appears. 
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• If you want to sort data based on a selected column, Choose Continue with the selection or if you want 

sorting based on other columns, choose Expand Selection. 

• You can Sort based on the below Conditions. 

o Values − Alphabetically or numerically. 

o Cell Color − Based on Color of Cell. 

o Font Color − Based on Font color. 

o Cell Icon − Based on Cell Icon. 



 

 
 

173 
 

 

• Clicking Ok will sort the data. 
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Sorting option is also available from the Home Tab. Choose Home Tab » Sort & Filter. You can see the same 

dialog to sort records. 
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10. FILTERS  

Filtering data in MS Excel refers to displaying only the rows that meet certain conditions. (The other rows gets 

hidden.) 

Using the store data, if you are interested in seeing data where Shoe Size is 36, then you can set filter to do this. 

Follow the below mentioned steps to do this. 

• Place a cursor on the Header Row. 

• Choose Data Tab » Filter to set filter. 

 

• Click the drop-down arrow in the Area Row Header and remove the check mark from Select All, which 

unselects everything. 

• Then select the check mark for Size 36 which will filter the data and displays data of Shoe Size 36. 

• Some of the row numbers are missing; these rows contain the filtered (hidden) data. 

• There is drop-down arrow in the Area column now shows a different graphic — an icon that indicates the 

column is filtered. 
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Using Multiple Filters 

You can filter the records by multiple conditions i.e. by multiple column values. Suppose after size 36 is filtered, 

you need to have the filter where color is equal to Coffee. After setting filter for Shoe Size, choose Color column 

and then set filter for color. 



 

 
 

177 
 

 

11. DATA VALIDATION 

MS Excel data validation feature allows you to set up certain rules that dictate what can be entered into a cell. For 

example, you may want to limit data entry in a particular cell to whole numbers between 0 and 10. If the user 

makes an invalid entry, you can display a custom message as shown below. 
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Validation Criteria 

To specify the type of data allowable in a cell or range, follow the steps below, which shows all the three tabs of 

the Data Validation dialog box. 

• Select the cell or range. 

• Choose Data » Data Tools » Data Validation. Excel displays its Data Validation dialog box having 3 tabs 

settings, Input Message and Error alert. 

Settings Tab 

Here you can set the type of validation you need. Choose an option from the Allow drop-down list. The contents 

of the Data Validation dialog box will change, displaying controls based on your choice. 

• Any Value − Selecting this option removes any existing data validation. 

• Whole Number − The user must enter a whole number.For example, you can specify that the entry must 

be a whole number greater than or equal to 50. 
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• Decimal − The user must enter a number. For example, you can specify that the entry must be greater than 

or equal to 10 and less than or equal to 20. 

• List − The user must choose from a list of entries you provide. You will create drop-down list with this 

validation. You have to give input ranges then those values will appear in the drop-down. 

• Date − The user must enter a date. You specify a valid date range from choices in the Data drop-down list. 

For example, you can specify that the entered data must be greater than or equal to January 1, 2013, and 

less than or equal to December 31, 2013. 

• Time − The user must enter a time. You specify a valid time range from choices in the Data drop-down 

list. For example, you can specify that the entered data must be later than 12:00 p.m. 

• Text Length − The length of the data (number of characters) is limited. You specify a valid length by using 

the Data drop-down list. For example, you can specify that the length of the entered data be 1 (a single 

alphanumeric character). 

• Custom − To use this option, you must supply a logical formula that determines the validity of the user’s 

entry (a logical formula returns either TRUE or FALSE). 
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Input Message Tab 

You can set the input help message with this tab. Fill the title and Input message of the Input message tab and the 

input message will appear when the cell is selected. 
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Error Alert Tab 

You can specify an error message with this tab. Fill the title and error message. Select the style of the error as stop, 

warning or Information as per you need. 
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12. CHARTS 

A chart is a visual representation of numeric values. Charts (also known as graphs) have been an integral part of 

spreadsheets. Charts generated by early spreadsheet products were quite crude, but thy have improved significantly 

over the years. Excel provides you with the tools to create a wide variety of highly customizable charts. Displaying 

data in a well-conceived chart can make your numbers more understandable. Because a chart presents a picture, 

charts are particularly useful for summarizing a series of numbers and their interrelationships. 

Types of Charts 

There are various chart types available in MS Excel as shown in the below screen-shot. 
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• Column − Column chart shows data changes over a period of time or illustrates comparisons among items. 

• Bar − A bar chart illustrates comparisons among individual items. 

• Pie − A pie chart shows the size of items that make up a data series, proportional to the sum of the items. 

It always shows only one data series and is useful when you want to emphasize a significant element in the 

data. 

• Line − A line chart shows trends in data at equal intervals. 

• Area − An area chart emphasizes the magnitude of change over time. 

• X Y Scatter − An xy (scatter) chart shows the relationships among the numeric values in several data series, 

or plots two groups of numbers as one series of xy coordinates. 

• Stock − This chart type is most often used for stock price data, but can also be used for scientific data (for 

example, to indicate temperature changes). 

• Surface − A surface chart is useful when you want to find the optimum combinations between two sets of 

data. As in a topographic map, colors and patterns indicate areas that are in the same range of values. 

• Doughnut − Like a pie chart, a doughnut chart shows the relationship of parts to a whole; however, it can 

contain more than one data series. 
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• Bubble − Data that is arranged in columns on a worksheet, so that x values are listed in the first column 

and corresponding y values and bubble size values are listed in adjacent columns, can be plotted in a bubble 

chart. 

• Radar − A radar chart compares the aggregate values of a number of data series. 

Creating Chart 

To create charts for the data by below mentioned steps. 

• Select the data for which you want to create the chart. 

• Choose Insert Tab » Select the chart or click on the Chart groupto see various chart types. 

• Select the chart of your choice and click OK to generate the chart. 

 

Editing Chart 

You can edit the chart at any time after you have created it. 

• You can select the different data for chart input with Right click on chart » Select data. Selecting new 

data will generate the chart as per the new data, as shown in the below screen-shot. 
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• You can change the X axis of the chart by giving different inputs to X-axis of chart. 

• You can change the Y axis of chart by giving different inputs to Y-axis of chart. 

• Pivot Charts 

• A pivot chart is a graphical representation of a data summary, displayed in a pivot table. A pivot chart is 

always based on a pivot table. Although Excel lets you create a pivot table and a pivot chart at the same 

time, you can’t create a pivot chart without a pivot table. All Excel charting features are available in a pivot 

chart. 

• Pivot charts are available under Insert tab » PivotTable dropdown » PivotChart. 

• Pivot Chart Example 

• Now, let us see Pivot table with the help of an example. Suppose you have huge data of voters and you 

want to see the summarized view of the data of voter Information per party in the form of charts, then you 

can use the Pivot chart for it. Choose Insert tab » Pivot Chart to insert the pivot table. 
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•  

• MS Excel selects the data of the table. You can select the pivot chart location as an existing sheet or a new 

sheet. Pivot chart depends on automatically created pivot table by the MS Excel. You can generate the pivot 

chart in the below screen-shot. 

•  
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QUESTIONS 

Part-A 

1. What is a Microsoft Excel? List out some applications. 

2. What is Quick Access toolbar? 

3. Draw a Ribbon of MS-Excel? 

4. What is Absolute Cell Reference? Give Examples? 

5. What is Mixed Cell Reference? Give Examples? 

6. “Function Arguments”-Explain in MS-Excel 

7. What is sorting? 

Part-B 

1. Explain Function by Categories. 

2.    

a) Explain the Various formats of a cell? 

b) What is a pivot table? Explain with Example. 

3. How to copy a formula in MS- Excel? What are the various options available? 

4. Explain the different features of conditional formatting? What are the options available? 

5.  

a) Explain sorting and filtering 

b) “Data Validation”-What do you mean? 

6. What are the different types of charts available in MS-Excel? How to create and edit a chart? 
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UNIT 4 
MASTER SLIDE 

In Microsoft PowerPoint, the Slide Master is the top slide that controls all information about the theme, layout, 

background, color, fonts, and positioning of all slides. Using the Slide Master can be an easy way to adjust the 

look of an existing theme or make overall changes to all slides in your presentation. 

How to view the Slide Master 

To view a Slide Master, click View at the top of PowerPoint and then click the Slide Master icon. Once in the 

Slide Master view, you can edit the Slide Master by clicking on the top slide and choosing the theme, font, color, 

or other settings you want for the presentation. If there are any slides you do not want in your 

presentation, highlight the slide and press delete. 

 

How to rename the Slide Master 

To make it easier to find your Slide Master right-click on the Slide Master and click Rename Master. In the 

Rename box type your new name and click the Rename button. 

Getting back to normal view 

After your changes are made to the Slide Master, click the Close master view button, or click View and 

then Normal to switch back to the normal view. 

What to do after editing the Slide Master 

After selecting the Slide Master (or any of the layout slides) when back in normal view, click the down arrow on 

the New Slide button under Home. Then select any of the new slides you have modified. 

https://www.computerhope.com/jargon/h/highligh.htm
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INSERT  IMAGES 

 

To insert a picture from a file: 

1. Select the Insert tab, then click the Pictures command in the Images group. 

2. A dialog box will appear. Locate and select the desired image file, then click Insert. 

3. The picture will appear on the currently selected slide. 

You can also click the Pictures command in a placeholder to insert images. 
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Inserting online pictures 

If you don't have the picture you want on your computer, you can find a picture online to add to your 

presentation. PowerPoint offers two options for finding online pictures: 

• OneDrive: You can insert an image stored on your OneDrive (previously called Sky Drive). You 

can also link other online accounts with your Microsoft account, such as Facebook or Flickr. 

• Bing Image Search: You can use this option to search the Internet for images. By default, Bing 

only shows images that are licensed under Creative Commons, which means you can use them 

for your own projects. However, you should go to the image's website to see if there are any 

restrictions on how it can be used. 

How to insert an online picture: 

1. Select the Insert tab, then click the Online Pictures command. 

 

2. The Insert Pictures dialog box will appear. 

3. Choose Bing Image Search or your OneDrive. In our example, we'll use Bing Image Search. 

 

4. Press the Enter key. Your search results will appear in the dialog box. 

5. Select the desired image, then click Insert. 

6. The image will appear on the currently selected slide. 

You can also click the Online Pictures command in a placeholder to insert online images. 
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When adding images, videos, and music to your own projects, it's important to make sure you have the legal right 

to use them. Most things you buy or download online are protected by copyright, which means you may not be 

allowed to use them.  

Moving and resizing pictures 

Once you've inserted a picture, you may want to move it to a different location on the slide or change its size. 

PowerPoint makes it easy to arrange pictures in your presentation. 

To select a picture: 

Before you can modify a picture, you'll need to select it. 

• Simply click to select a picture. A solid line will appear around a selected picture. 
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To resize a picture: 

• Click and drag the corner sizing handles until the picture is the desired size. 

 

The corner sizing handles will resize a picture while preserving its original aspect ratio. If you use the side 

sizing handles, the image will become distorted. 

To rotate a picture: 

• Click and drag the arrow above an image to rotate it right or left. 

 

Hold the Shift key on your keyboard when rotating an image to limit the rotation angle. 

To move a picture: 

• Click and drag to move a picture to a new location on a slide. 
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To delete a picture: 

• Select the picture you want to delete, then press the Backspace or Deletekey on your keyboard. 

You can access even more picture formatting options from the Format tab. We'll talk more about these options in 

our lesson on Formatting Pictures. 

 

Inserting screenshots 

Screenshots are basically snapshots of your computer screen. You can take a screenshot of almost any program, 

website, or open window. PowerPoint makes it easy to insert a screenshot of an entire window or a screen 

clipping of part of a window in your presentation. 

To insert screenshots of a window: 

1. Select the Insert tab, then click the Screenshot command in the Imagesgroup. 

2. The Available Windows from your desktop will appear. Select the windowyou want to capture as 

a screenshot. 

https://edu.gcfglobal.org/en/powerpoint2013/formatting-pictures/1/


 

 
 

195 
 

 

3. The screenshot will appear on the currently selected slide. 

To insert a screen clipping: 

1. Select the Insert tab, click the Screenshot command, then select Screen Clipping. 

 

2. A faded view of your desktop will appear. Click and drag to draw the area you want to capture as a 

screen clipping. 

 

3. The screen clipping will appear on the currently selected slide. 
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HOW TO ADD VIDEO FROM A FILE 

The first approach, adding video to PowerPoint using a file on your computer, is fairly straightforward. 

STEP 1: CHOOSE YOUR SLIDE. 

First thing’s first, open your presentation and navigate to the slide you want to add a video to. You can always 

reorder your slides later if you change your mind. 

STEP 2: SELECT YOUR VIDEO. 

Click “Insert” in the top navigation bar, select “Movie” and then click “Movie from File.” From there, select the 

file you’d like to insert. 

 

Alternatively, select “Media” (or “Movie,” depending on whether you’re using a Mac or PC) from the “Insert” 

section of the Home menu in the PowerPoint control panel and follow the same steps as above. 
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STEP 3: FORMAT YOUR VIDEO. 

Once your video is inserted, you can make adjustments, including whether you want it to play automatically or 

upon being clicked, choosing a thumbnail, adding a border, visual effects, and more. Start your slideshow to make 

sure everything is to your liking, and you’re done! 

How to add a video from YouTube 

STEP 1: CHOOSE YOUR SLIDE. 

Stop us if this sounds familiar: Open your presentation and navigate to the slide in question. You can always 

reorder your slides later if you change your mind. 

STEP 2: FIND YOUR YOUTUBE VIDEO. 

You probably saw this one coming. Once you’ve navigated to the video, click “SHARE,” then “EMBED,” and 

look over the options for your embedded file before you copy the code. You may want to uncheck the suggested 

videos, for instance. Then copy that code by pressing “CTRL+C” or “Command +C,” and return to PowerPoint. 

STEP 3: INSERT YOUR VIDEO. 

Click the “Insert” tab, select “Video,” and then click “Online Video.” Older versions of PowerPoint will say 

“Video from Website.” Paste your embed code into the field that appears. You can also embed videos from other 

sources, such as Vimeo, using either this approach, or the app mentioned in the support page linked to above. 

STEP 3: FORMAT YOUR VIDEO. 
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Click the “playback” tab to decide whether you want your video to play automatically or upon being clicked, 

choose a thumbnail, add a border, visual effects, and more. Start your slideshow to make sure everything is to 

your liking, and you’re done! 

Google Slides 

If you’re creating a presentation in Google Slides, rather than PowerPoint, then we’ve got you covered there as 

well. 

STEP 1: CHOOSE YOUR VIDO. 

Navigate to the slide you’ll be playing your video on, click “Insert” from the navigation bar, and select “Video.” 

You’ll be given the option to search within YouTube for a video, input a YouTube URL, or select a file from your 

Drive. Choose one, select your desired video, and it’ll appear on your slide. 

 

STEP 2: FORMAT YOUR VIDEO. 

Feel free to position your video however you choose on your slide, as well as drag from the corner of the video to 

resize it. You can also right-click on the video to open “Video Options,” which will allow you to choose the 

points at which your video will start and end, as well as whether you’d like the sound to play, and whether or not 

you want your video to autoplay. 
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CHARTS AND GRAPHS 

Click Insert > Chart. 

 
Click the chart type and then double-click the chart you want. 

 
In the worksheet that appears, replace the placeholder data with your own information. 
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When you’ve finished, close the worksheet. 

OLE 

OLE is supported by many different programs, and OLE is used to make content that is created in one program 

available in another program. For example, you can insert an Office Word document in an Office Excel 

workbook. To see what types of content that you can insert, click Object in the Text group on the Insert tab. 

Only programs that are installed on your computer and that support OLE objects appear in the Object type box. 

Embed an object in a worksheet 

1. Click inside the cell of the spreadsheet where you want to insert the object. 
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2. On the Insert tab, in the Text group, click Object  . 

 
3. In the Object dialog box, click the Create from File tab. 

4. Click Browse, and select the file you want to insert. 

5. If you want to insert an icon into the spreadsheet instead of show the contents of the file, select the Display as 

icon check box. If you don’t select any check boxes, Excel shows the first page of the file. In both cases, the 

complete file opens with a double click. Click OK. 

Insert a link to a file 

You might want to just add a link to the object rather than fully embedding it. You can do that if your workbook 

and the object you want to add are both stored on a SharePoint site, a shared network drive, or a similar location, 

and if the location of the files will remain the same. This is handy if the linked object undergoes changes because 

the link always opens the most up-to-date document. 

1. Click inside the cell of the spreadsheet where you want to insert the object. 
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2. On the Insert tab, in the Text group, click Object  . 

 
3. Click the Create from File tab. 

4. Click Browse, and then select the file you want to link. 

5. Select the Link to file check box, and click OK. 

Create a new object from inside Excel 

You can create an entirely new object based on another program without leaving your workbook. For example, if 

you want to add a more detailed explanation to your chart or table, you can create an embedded document, such 

as a Word or PowerPoint file, in Excel. You can either set your object to be displayed right in a worksheet or add 

an icon that opens the file. 

 

1. Click inside the cell of the spreadsheet where you want to insert the object. 
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2. On the Insert tab, in the Text group, click Object  . 

 
3. On the Create New tab, select the type of object you want to insert from the list presented. If you want to insert 

an icon into the spreadsheet instead of the object itself, select the Display as icon check box. 

4. Click OK. Depending on the type of file you are inserting, either a new program window opens or an editing 

window appears within Excel. 

5. Create the new object you want to insert. 

When you’re done, if Excel opened a new program window in which you created the object, you can work 

directly within it. 

 

ANIMATION 

So first, let’s setup our Excel file. Start a new document and select Page Layout either in the Layout tab or with 

the bottom left buttons: 
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In the zoom level dropdown menu select One Page: 

 

Now the pages always stay in the same position whenever you scroll. Pages are now frames for our animation. 

To make the cells into square pixels first select all (Command-A) then go to the Cells > Format menu, in the 

Home tab. There, change the Row Height to 0.55cm and the column width to 0.55cm. 

 

You can use smaller or larger pixels, but this pixel size on US Letter-sized pages gives us a resolution of 31x40 

px which is great for the simple animations we’ll be creating. “31x40” is mildly infuriating and our character will 

be more centered if the number of horizontal pixels is even, but trying to change all column widths equally only 

results in odd numbers for some reason, so to get the resolution down to 30x40 I had to change the widths of 

columns A, B and AC, AD to 0.65cm. 

All Cells, no Numbers 

The canvas is ready. We’ll be making a jumping man animation, and it will be “loopable” so that we can easily 

extend the duration of the animation. 
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Our very simple character will have a 2x3 px head. You can change your character’s design but you might want 

to go to a drawing application like Photoshop for that, so you can more freely try alternatives before taking the 

time to recreate the design in spreadsheet cells. 

I suggest you locate the head on columns O and P and rows 21-23. Select those cells: 

 

Select the cells for the first part of the guy: his head. 

Right-click on the selected cells and go to Format Cells… (or press Command-1) then go to the Fill tab and select 

a dark color, You can use a custom color but since you’ll be doing this many times it might be preferable to stick 

to the theme colors. 

The character’s torso will be 4x6 px, his legs 6 px vertically and his arms 4px across. 
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You can increase selected cells and blocks of cells by holding down the Command key. 

We’ll add a shadow using the pattern option. You could also use a light grey for the shadow but I like the retro 

feel the pattern gives. Patterns are in the same Format Cells > Fill tab but they’re in the Foregroundoptions. 

 

Now frame 1 (out of 11) is complete. Select all the cells from that page and copy them, then scroll down to the 

second page, select cell A1 and paste. 

The changes for frame 2 would be the man flexing his legs for the jump just by shortening them by 1px, and also 

bringing his arms down 1 px at the shoulders and another 1 px at the middle, like this: 
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In frame 3 we’ll have the man flexing his legs a little bit more, so we cut the legs short by another pixel. And 

we’ll lower the arms a little bit more, so that they are diagonal: 

 

You can move large portions of the graphic by copying and pasting blocks of cells rather than editing all the cells 

manually. 

In frame 4 his arms will remain the same but he’ll be already in the air, legs fully extended to 6 px tall and the 

whole body 1 px above his shadow, which stays in the same place throughout the animation. 
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For frame 5 we’ll extend his arms horizontally again. You can paste frame 1 here, only he should be higher in the 

air, 2 px over last frame—which means 3 px above his shadow. As a fun little detail I’m making the shadow 

softer as he goes farther off the ground without changing the color but by changing the pattern to a slightly lighter 

one. 

 

In frame 6 he is another 2 px higher than in frame 5 and his arms are going slightly higher: 
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In frame 7 he only rises 1 more pixel but his arms rise a little bit more and I made his shadow a slightly lighter 

pattern again: 

 

In frame 8 he doesn’t rise anymore, he remains in the same position as he’s at the peak of the jump, only his arms 

go one pixel higher to form diagonals: 
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In frame 9 he begins to go back down, just by 1 px. His shadow is a bit darker. You could copy and paste frame 6, 

the only difference is that we’ll delay the arms’ motion by a couple of frames, so his arms will still be diagonals 

as in frame 8: 
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Frame 10 should be like frame 5 but with the arms in the position of frame 7: 

 

Frame 11 closes the loop, he’s still in the air but the next frame would be the first we made. The shadow returns 

to the original pattern. It’s like frame 4 but the arms are as they were in frame 6: 

 

Turn Excel Into an Animation Viewer 

Now that the animation is complete you’ll want to select the bottom right cell from page 11 and scroll up to page 

1, and holding down shift select the top left cell from that page to copy the whole animation. You’ll go to page 12 

and select the top left cell (A1) and paste. Paste again down at page 23 and repeat as many times as you want. I 

think looping it 4 times does the trick. 
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To wrap up the file you’ll want to go to Layout > View, and uncheck Headings, to avoid the cell numbers moving 

the page slightly when they go into four digits. You can also uncheck Gridlines to not see the cell borders, it’s 

cleaner but it looks less like a spreadsheet, so it’s up to you if you’ll leave that on or off: 

 

Then resize the window to match the page proportions and give the spreadsheet a clever name: 

You could also add some instructions or title to the first page: 

 

And it’s done! Just scroll from the beginning of your spreadsheet to the end to see the animation, or check out the 

video below to see it in action: 

Excel Hyperlinks and Hyperlink Function 

Create hyperlinks by dragging and dropping, or with the HYPERLINK function. Remove hyperlinks manually, or 

with a macro. Make a table of contents with a macro. 

Four Ways to Create Hyperlinks 

https://www.contextures.com/excelhyperlinkfunction.html#create
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Stop Automatic Hyperlinks 

Use the Excel HYPERLINK Function 

Remove Hyperlinks 

Point to Hyperlink 

Create Table of Contents With Hyperlinks 

Pivot Table - Fake Hyperlinks 

Get Hyperlink Address 

Hide Sheets After Hyperlink 

Download the Sample Files 

Create Excel Hyperlinks 

In an Excel worksheet, you can create a hyperlink in any cell. Then, click that hyperlink to go to the specificed 

location. 

Here are four ways create a hyperlink -- click a link to go to those instructions, below: 

• type the URL 

• or use the Insert Hyperlink command 

• or drag and drop 

• or use the HYPERLINK function 

 

Type a Website URL 

If you type a valid website address in a cell, Excel should automatically create a hyperlink, when you press Enter 

For example, 

1. In cell B3, type the address of the Contextures website: https://www.contextures.com 

2. Press Enter 

The text changes to a hyperlink, and you can click the link to go to the Contextures website. 

If you want to stop hyperlinks from being automatically created, follow the instructions here. 

https://www.contextures.com/excelhyperlinkfunction.html#stop
https://www.contextures.com/excelhyperlinkfunction.html#videoformula
https://www.contextures.com/excelhyperlinkfunction.html#removemanual
https://www.contextures.com/excelhyperlinkfunction.html#point
https://www.contextures.com/excelhyperlinkfunction.html#tocvba
https://www.contextures.com/excelhyperlinkfunction.html#videopivot
https://www.contextures.com/excelhyperlinkfunction.html#extract
https://www.contextures.com/excelhyperlinkfunction.html#hide
https://www.contextures.com/excelhyperlinkfunction.html#download
https://www.contextures.com/excelhyperlinkfunction.html#insert
https://www.contextures.com/excelhyperlinkfunction.html#insert
https://www.contextures.com/excelhyperlinkfunction.html#drag
https://www.contextures.com/excelhyperlinkfunction.html#formula
https://www.contextures.com/excelhyperlinkfunction.html#stop


 

 
 

214 
 

 

Insert a Hyperlink 

Another way to add a hyperlink is by using a built-in Excel command. 

In this example, a hyperlink to the Google site is created: 

• Select the cell where you want the hyperlink 

• On the Excel Ribbon, click the Insert tab 

• Click the Hyperlink command 

 

• In the Insert Hyperlink window, click in the Text to Display box 

• Delete the default text, and type the text that you want to show in the selected cell -- Google Site in this 

example 

• At the left, click on "Existing File or Web Page" 

• Click in the Address box, and type the website URL -- www.google.com (Excel will automatically add the 

"https://") 
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(Optional) To set the text for the Screen Tip that appears when you point to a cell that contains a hyperlink: 

• Click the Screen Tip button 

• Type the text for the screen tip -- Google Website 

• Click OK 

• Click OK to add the Hyperlink to the cell. 

When you pont to the hyperlink, its screen tip appears. 

 

Create Hyperlinks with Drag and Drop 

If you're creating hyperlinks within an Excel file, the quickest and easiest method is to use drag and drop. For 

example, you could create a table of contents sheet (TOC), in a workbook, with links to other sheet. 

To see a quick overview of how you can create a hyperlink by drag and drop, you can watch this short video. 

The written instructions are below the video. 

If you have trouble dragging to a different sheet, drag to a nearby blank cell, then cut and paste onto the other 

sheet. This animated gif shows those steps. 

https://www.contextures.com/excelhyperlinkfunction.html#draginst
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Create a Hyperlink With Drag and Drop 

Follow these steps to create drag and drop hyperlinks. 

1. First, save the workbook, if it hasn't been saved yet. (In a new workbook, that hasn't been saved, this 

technique won't work.) 

2. Then, click on a cell that you want to link to. (You're going to drag that cell to another sheet, where you 

want to create a hyperlink) 

3. Point to the cell's border, and press the right mouse button. 

4. To drag the cell to another sheet, press the Alt key, and drag the cell onto the other sheet's tab. 

 

5. Once the other sheet is activated, release the Alt key, and drag to the cell where you want the hyperlink 

6. Release the right mouse button, and in the popup menu, click Create Hyperlink Here 
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7. A hyperlink will appear in the cell, with the text from the original cell. 

 

Stop Automatic Hyperlinks in Excel 

If you don't want hyperlinks automatically created when you type a website address, you can turn the 

hyperlinking feature off. To see a quick overview of how you can stop automatic hyperlinks from being created 

automatically, you can watch this short video. The written instructions are below the video. 

To turn the hyperlink option off:: 

1. On the Excel Ribbon, click the File tab, then click Options 

2. Click the Proofing category, and click the AutoCorrect Options button 

3. On the AutoFormat As You Type tab, remove the check mark from Internet and network paths with 

hyperlinks 

4. Click OK, twice, to close the dialog boxes 



 

 
 

218 
 

 

Use the HYPERLINK Function 

 

 

 

To see a quick overview of how you can create a hyperlink with the HYPERLINK function, you can watch this 

short video. Written instructions are below the video 

Below are the written instructions for using the HYPERLINK function to: 

• link to a website or email 

• link to an Excel file 

Create a Hyperlink to a Website or Email 

If there is a list of email addresses or website addresses in Excel, you can create a hyperlink for each row, in a 

separate column. In this example, there is a name in column A, and a website URL or an email address in column 

B. Hyperlinks will be created in column C. 

You'll use the HYPERLINK function, which takes two arguments: 

 

• Link_Location: This is the email address or URL. For an email address, start with "mailto:" and for a 

URL, start with "https://" 

• Friendly Name: This argument is optional, and lets you specify a "friendly" name for the link. For 

example, instead of a long URL, you can show a company name, or short description. 

To create a hyperlink for each address: 

1. In cell C2, type the formula: =HYPERLINK(B2,A2) 

https://www.contextures.com/excelhyperlinkfunction.html#formulawritten
https://www.contextures.com/excelhyperlinkfunction.html#linkwebsite
https://www.contextures.com/excelhyperlinkfunction.html#linksheet
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2. Press Enter, to see the hyperlink in C3. It uses the link in cell B2, and the text in cell A2 is shown in cell 

C2, as the Friendly Name. 

3. Copy the formula down to the remaining rows. 

 

HYPERLINK Formula to Excel File 

With a HYPERLINK formula, you can link to a location in the current Excel workbook, or to another Excel file. 

Watch this video to see the steps, and the written instructions are below the video. 

Below are the written instructions linking to an Excel file: 

1) link within the same file 

2) link to another Excel file 

Link Within the Same File 

You can use a HYPERLINK formula to create a link to goes to a cell or range somewhere within the current 

workbook. The trick is to add a pound sign (#) at the start of the address. 

Here are three examples of HYPERLINK formulas within the same workbook: 

• Type the Address: Start with a #, then type the sheet name and cell reference. Optional - Type a friendly 

name, such as "Budget" to appear in the cell: 

=HYPERLINK("#Sheet2!B2","Budget") 

• Use Cell References: Use the & operator to create a link location. Here, the sheet name is in cell B5, the 

cell address is in C5, and the friendly name is in cell D5. 

=HYPERLINK("#"&"'" & B5 & "'!" & C5,D5) 

https://www.contextures.com/excelhyperlinkfunction.html#linkexcel
https://www.contextures.com/excelhyperlinkfunction.html#samefile
https://www.contextures.com/excelhyperlinkfunction.html#otherfile
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• Type a Range Name: For a link to a workbook-level named range in the same workbook, just use the 

range name as the link location. 

=HYPERLINK("#StartCell","StartCell") 

Link to Another Excel File 

To create a link to another Excel file, in the same folder, just use the file name as the link_location argument for 

the HYPERLINK function. 

=HYPERLINK("MyFileC.xlsx","FileC") 

For files that are up a level or more in the hierarchy, use two periods and a backslash for each level. 

• In this example, the file is 1 level up. 

=HYPERLINK("..\MyFileB.xlsx","FileB") 

• In this example, the file is 2 levels up. 

=HYPERLINK("..\..\MyFileA.xlsx","FileA") 

Remove Hyperlinks 

Below are the instructions for two methods of removing hyperlinks 

Manually removing hyperlinks, 

and a macro to remove hyperlinks 

Manually Remove Hyperlinks 

In Excel 2010 or later: 

In Excel 2010, you can quickly remove hyperlinks from selected cells. (Thanks to Sam for this tip.) 

1. Select cell(s) that contain hyperlinks 

https://www.contextures.com/excelhyperlinkfunction.html#manremove
https://www.contextures.com/excelhyperlinkfunction.html#removevba
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2. Right click on any selected cell 

3. Click Remove hyperlinks 

To see the steps, watch this Excel Quick Tips video. 

In Excel 2007 and earlier versions: 

To remove hyperlinks from a group of cells, you can copy and paste the cells as values. To see the steps, watch 

this Excel Quick Tips video. 

Macro to Remove All Hyperlinks in Selected Cells 

Instead of manually removing the hyperlinks, you can you can use the following macro code. It deletes all 

hyperlinks in the selected cells, and leaves just the cell text. 

Copy this code into a regular module in your workbook, then select the cells, and run the delHyperlinks macro. 

Sub delHyperlinks() 

'posted by Rick Rothstein 

  Selection.Hyperlinks.Delete 

End Sub 

Point to Hyperlink 

Follow these steps to make the pointing hand appear anywhere in a hyperlink cell, and see how to select a 

hyperlinked cell, without following the link. 

Show the Pointing Hand 

If a wide cell contains a short hyperlink, the pointing hand will only appear when it's over the text, not in the 

empty space. To fix that: 

• Select the cell(s) 

• On the Home tab of the Excel Ribbon, click the Wrap Text command. 
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Select a Hyperlink Cell 

If you need to select a hyperlink cell, perhaps to edit the text, without following the link: 

• Point to the cell, and press the left mouse button for a couple of seconds. 

• The pointer will change to a big white plus sign, to show that the cell was selected. 

• You can now edit the hyperlink cell 

QUESTIONS 

Part-A 

1. What is a Power Point? Where it is used? 

2. What do you mean by a Slide master? 

3. What are the options for inserting online pictures 

4. What is OLE? Explain. 

5. Can Animation be done is Power Point. If So, how? 

6. What is hyperlink? 

7. How to link a hyperlink within the same file? 

Part-B 

1. What is a Power point? How to insert different pictures in a PowerPoint? 

2.  

a) Explain the steps to insert a video in a PowerPoint? 

b) How to transfer a hyperlink formula to MS-Excel file? 

3. Explain how to insert animation in a PowerPoint? 

4. What is a hyperlink? How to create and insert a hyperlink? 
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UNIT V 

ONLINE  FORMS (GOOGLE FORM) 

Building Your First Google Form 

 

 

The simplest way to start building a form is right from the Google Forms app. Go to docs.google.com/forms, then 

either choose a template or start a blank form. 

There's also a link to Google Forms in Docs, Sheets, and Slides: click File -> New -> Form to start a new blank 

form. Or, in Google Sheets, click Tools -> Create a Formto start a blank new form that's automatically linked to 

that spreadsheet. That's the quickest way to get data into a new or existing spreadsheet: open the spreadsheet 

where you want the data, start a form, and the form responses will automatically be saved there without any extra 

clicks. 

 
The Forms editor is straightforward. Your form fills the center of the screen, with space for a title and description 

followed by form fields. Click a form field to edit it and add a question. Use the dropdown box next to the field to 

choose the field type, such as multiple choice, checkboxes, short answer, and so on.  

Google Forms offers several settings options. The floating toolbar on the right lets you add more form fields. On 

the top right menu you can change the form's color scheme, preview the form, use the Send button to share the 

form, and access other extra options, including installing add-ons for Forms. Switch from the Questions tab to 

the Responses tab in your form editor to see current responses to your form and link it to a spreadsheet. 

All you need to do is add your questions and send the form out, so let's look at the form options and what you can 

https://docs.google.com/forms/?utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
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do with each. 

Google Forms Field Options 

 

Google Forms includes 12 field types: 9 question types, along with text, photo, and video fields. Just click the + 

icon in the right sidebar to add a new question, or click the text, photo, or video icons to add media to your form. 

Each field includes a copy button to duplicate the field, for a simple way to add similar questions to your form. 

There's also a delete button, options to make the field required, and a menu with extra options on the right side. 

You can switch question types at any time, though do note that your field settings and questions will reset if you 

switch from multiple choice, checkbox, or menu to any of the other question types. And, to quickly fill in 

questions in fields, just press enter to start adding another one. 

Quick Tip: Accidentally remove a form element 

or add one too many? Just tap CMD + Z or Ctrl + Z to undo, just as you would in a document. 

Here's what each field type offers: 

 
Title and Description: The title and description fields are added automatically to every form and field—though 

the description is hidden by default on most fields—and you can add an extra title block anywhere with 

the Tt button. You can leave the title and description blank on questions, but the main form title must be filled in. 

The description doesn't include formatting options—though you can include links (in shortened format, 

like zapier.com, or as the full length style like https://zapier.com/), and form readers can click those to see your 

site or related material. 
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Short Answer: This field is perfect for asking for small bits of text: names, email addresses, values, and more. 

You get one line of text to answer the question—though your users could actually enter as much text as they 

want. 

To make sure you get the answers you need, this field includes number, text, length, and regular expression data 

validations. Number validations help you watch for ranges of values, while text validations are perfect to watch 

for email addresses or links. 

Paragraph: Much the same as the short answer field, this is a field for text—long-form text. Length and regular 

expression are the only data validations available here, so only use it when you want detailed feedback or longer 

notes in the answer. 

 
Multiple Choice: The default field for new questions in a Google Form, multiple choice lets you list options and 

have users select one. You can then have the form jump to another section based on the answer or have the 

answer options shuffled to prevent bias. 

Checkboxes: Similar to multiple choice, this field lets you list answers and have users select as many as they 

want. It also includes data validation to require users to select a specific number of options. It doesn't include 

section jumps, however. 

Dropdown: Want all of the answer options in a menu? This field's for you. It's the exact same as the multiple 
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choice field—with the same section jump and shuffle options—only this time the answers are in a menu. This is 

useful for keeping your form compact when there are many answer options. 

 
Linear Scale: The field to let people select a number in a range, linear scale lets you set a scale from 0 or 1 to 2-

10 with labels for the lowest and highest options. And yes, emoji work for labels, too. 

 
Multiple Choice Grid: This is perhaps the most confusing field, as the fields are displayed in a list rather than in 

the grid as they'll appear to readers. Essentially, you'll add questions as rows, and options about them as columns. 

You can include as many rows and columns as you want, though do note that readers will have to scroll right to 

see more than 6 columns on desktop browsers or just 3 columns on mobile. You might want to keep the form 

preview open while setting up grid questions—just tap the eye icon on the top right, and refresh that page to see 

your changes. 
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Also, in addition to the standard option to require responses, the grid lets you require a response per row and can 

also limit users to only one response per column. 

 
Date: Want to ask for a specific date or time, perhaps to schedule an event or log an activity? The date field is the 

one you want to select. It can ask for a date and month and, optionally, the year and time as well. 

Do note that the date format will be shown in the default format for your location. If your Google Account is set 

to US English locale, dates will be formatted as MM/DD/YYYY; UK English accounts, on the other hand, will 

show dates as DD/MM/YYYY. Your users will see the date options in your locale's date format, unless they're 

logged into their Google Account, so be sure to keep that in mind when creating forms. 

You can change your Google Account locale along with your account language at  

Time: Time lets you request a length of time in hours, minutes, and (optionally) seconds, for a way to log how 

long an activity took. 

 
Image: Google Forms lets you upload an image, insert one from a link or Google Drive, or take a photo from 

your own webcam (as long as you have Flash installed). Or, you can search Google Images for photos, including 

royalty free stock photo and images from LIFE that are licensed to use inside Google Drive. 

Video: Google Forms only supports YouTube videos, which you can add either through search or with a link. 

Whether you've added images or videos, your form entry will have the standard title and description, along with 
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options to resize and show the video or image centered, left, or right aligned. 

 

With the questions out of the way, let's pull them together and make a complete form with sections and logic to 

route users to the correct questions. 

Form Sections and Logic 

 

Simple contact forms only need a few fields, but longer surveys can quickly get overwhelming with dozens of 

questions on one page. That's where sections come in handy: They let you break your form up into chunks to 

answer one set of questions at a time. 

Just click the last button the right toolbar to add a section below the current question. Each section includes its 

own title and description, along with an arrow button at the top to show or hide questions and keep your form 

editor tidy. 

You can drag-and-drop questions between sections, but you can't rearrange full sections. You could, instead, 

move the questions out and then delete that section. Or, if you want to reuse a section, just click the section's 

menu and select Duplicate section for another copy of those questions. 
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That's a perfect way to start a form with logic jumps. Say you want to ask a respondent followup questions based 

on their answer—perhaps to ask which meat an event attendee wants, but only if they're not vegetarian. 

Just add sections with the optional questions, and then either add a section jump to the individual multiple choice, 

checkbox, or menu questions, or to the section itself. Make sure to think through where people who shouldn't see 

those questions are sent, too, perhaps with alternate questions in a separate section. Or, you can send them straight 

to the end of the form to submit their answers, if there's nothing else to ask. 

Be creative: Form sections and jumps let you turn your form into a mini-app, and they can be a great way to 

condense detailed surveys down into only the most important questions for each person. 

Quick Tip: Be sure to not select your current section's name, or you'll end up making a loop where respondents 

can never get to the end of your form. 

Build a Quiz 

https://zapier.com/learn/ultimate-guide-to-forms-and-surveys/simple-database-app-builders/
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Another way to make an interactive form is with Google Forms' Quiz mode. Inside your form settings, you'll find 

a Quizzes tab. Select Make this a quiz, and then choose whether to show the results immediately after the form is 

submitted or later once you review the answers. If you choose the latter, your form will need to require 

respondents to sign in with their Google account. 

You can then choose to show missed and correct answers, as well as a value for each option if you'd like. 

https://docs.googleblog.com/2016/06/give-feedback-faster-with-quizzes-in.html?utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
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With that enabled, you'll see a new Answer Key button on the bottom left of each question. Click it, then select the 

correct answer for the question. You can optionally add answer feedback both for correct and incorrect answers, 

with a link for respondents to view more info if you'd like. 

Note that quizzes only work with multiple choice, checkbox, and drop-down questions. 

Design Your Form 
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There's one spot where you don't have much option: your form's design. Google forms include a header color or 

image, along with lighter accent color as the background. By default, new forms come in purple, while template 

forms often include an image. 

Click the color palette icon in the top right to tweak your design, if only a little. You can choose from 15 colors, 

each a darker color for the header with a complimentary background shade. 

 

Click the photo icon to select a photo or Google Doodle-style drawing from Google's library as your form's 

header photo. Or, select one of your photos from Google Drive or upload a new one and crop it to fit in as a form 

header. Forms will then automatically select a background color that matches your photo. 

Some of the included header images are animated GIFs with burning candles, moving balls, and more. 

Unfortunately, if you add them to your form, they appear as a standard still image. Perhaps in the future Google 

Forms will get GIF support—for now, images and colors are the only design options in Forms. 

Note: If you add your own photo as a header, Google will only saved the cropped version of it to Drive. 

Store Form Responses in a Spreadsheet 
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Once you've created the form, you don't need to do anything extra to store respondents' answers in Google Forms. 

By default, it'll save each answer in the Responses tab, showing summary graphs and lists of answers. An 

individual response view shows the live form along with the results from each respondent. 

That's great for quick form results, but for more tools to analyze answers, you can link your form to a Google 

Sheets spreadsheet. Just click the green Sheets icon in the Responses tab or click Select Response Destination in 

the menu, then create a new spreadsheet or select an existing one to store the answers. 

Note: You can store results from multiple forms in one spreadsheet; each form's responses will be saved to a 

separate sheet. You cannot, however, save multiple forms' responses to a single sheet. 

 
One great thing about saving Google Forms entries to a Google Sheets spreadsheet: It's fast. Change your form 

field names, and they're automatically updated in your spreadsheet. Get a new entry, and it'll show up in the 
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spreadsheet as soon as your recipient clicks Submit. 

Note: You can change form questions and answer options at any time, but if you do, it won't change entries that 

have already been added to your spreadsheet. 

Google Forms always keeps a full copy of all your form data, so if you accidentally delete something from your 

spreadsheet, don't worry. Just open your Form response settings and unlink it from your spreadsheet, or 

click Form -> Unlink Form inside your spreadsheet. Then, reconnect the form to your spreadsheet, and Google 

Forms will add all the form data back to a new sheet. 

 
With your form data in the spreadsheet, you can use Google Sheets' formulas to calculate values or make custom 

graphs to visualize your data. Add conditional formatting to the spreadsheet, and you'll be able to see patterns in 

your form responses at a glance. 

There's one other handy extra with Sheets: notifications. Google Forms by default can email you whenever the 

form is filled out, but click Tools -> Notification Rules in Google sheets for more detailed options. There, you can 

choose to get emailed just once a day with a summary of all responses or whenever changes are made to a form 

entry. 

Tip: For more features, you can add Google Sheets add-ons to include formulas in survey responses, send 

customized notifications, and more. We'll look at those in-depth in chapter 6. 

Share Your Form 

You've made a form, and now it's time to share it with the world and get responses to your questions. Or perhaps 

you want to get feedback from your team on your form. Either way, here's what you need to do in Google Forms. 

Collaborate on Forms 

https://support.google.com/docs/answer/46977?utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
https://support.google.com/docs/answer/190718?hl=en&utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
https://support.google.com/docs/answer/190718?hl=en&utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
https://support.google.com/docs/answer/78413?utm_source=zapier.com&utm_medium=referral&utm_campaign=zapier
https://zapier.com/learn/google-sheets/best-google-sheets-addons/#forms
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One of Google Forms' best features is that you can share the core form with others to let them help you build and 

edit the form. The same sharing features you'd expect in Google Docs and Sheets are included with Forms. 

Just open the Forms menu and select Add Collaborators, then enter individual collaborators' email addresses. Or 

click the Change… link to make the form public to the web or just inside your organization. 

Tip: Want to make your own form template? Just make a form, then click the form's menu and select Make a 

copy. Or share your original form, and then everyone with the link can make their own copy–an easy way to make 

shared team template forms. 

Form Sharing Settings 
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Once your form is finished, be sure to check the form settings before sharing it with the world. Click the gear icon 

to open the settings, where you can add a confirmation page to your form. This works the same as the form 

description field with no formatting but support for links. 

You can also choose to share the form either only inside your organization or publicly with anyone who has the 

link. There are also options to collect their username (their Google Apps email address) or only allow one 

response (which requires respondents to log into their Google account). 

In the response options, you can let users submit another response, edit their responses, or see a summary of all 

responses. You can also have Google show a progress bar based on the number of completed sections or shuffle 

the question order. 
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Google Form interface in Thai with English questions 

There's one more thing to note: language. Google will show the form's interface in the default language for your 

recipients' location. If your readers are in Japan, say, and your form questions are in English, the UI text 

like Required and Submit will be in Japanese while your questions are in English. If that's an issue, you can add a 

note to the beginning of your form to remind people to set their Google language from google.com first. 

Share Finished Forms Online 

 
Ready to get responses to your form? Just click the Send button in the top right to share the form via email or 

social networks, copy a link to the form, or get an embed code to add it to your site. 

With the link, you can either copy a full-length link or get a shortened goo.gl/forms/ link to share more easily on 
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social networks. The embed option includes width and height options to fit the form within your site's design. 

 
Sharing the form via email includes an extra option: including the form in the email. This copies your actual form 

options into the email, and if your recipient uses Gmail, they can fill out the form inside their Gmail inbox, 

click Submit, and send in their answer without ever seeing your real form. That only works in Gmail, though—

Apple Mail shows the form fields but doesn't send the answers to Google Forms, while Outlook.com can't even 

open the form—so you might want to include a note with your form for non-Gmail users. 

Share Pre-filled Form 

 

Want to get feedback with a form partly filled in? Perhaps a contact clicks a button on your site that says they 

dislike one product, so you want the survey form to reflect that automatically. Or maybe you have a form that 

needs to be filled out with similar info each week, and you don't want to re-type it. 
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For cases like these, click the Get pre-filled link option in the Forms menu, then fill in the options you want on the 

form. Click Submit at the end, and Google will give you a unique link to share that copy of the form with the 

answers pre-filled. 

Share Paper or PDF Form 

 
Need to gather responses offline? Google Forms can help with that too. Just click Print in your Forms menu, and 

Google Forms will make a ballot-style copy of your form that you can print or save as PDF. 

Grids and multiple-choice options show pill buttons to fill in, while text fields include blank lines for answers. 

Once respondents have filled out your paper forms, just type their answers into your Google Sheets spreadsheet to 

save them along with your other form entries. 

2.CALENDAR 

Create a new calendar 

You can create calendars to keep track of different types of events. For example, you could create a calendar 

called "Soccer" that tracks upcoming practices and games.  

Set up a new calendar 

You can only create new calendars from a browser, and not from the Google Calendar app. Once the calendar is 

created, you'll see it on your browser and in the app. 

1. On your computer, open Google Calendar. 

2. On the left side, above "My calendars," click Add other calendars   New calendar. 

3. Add a name and description for your calendar 
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4. Click Create calendar. 

5. If you want to share your calendar, click on it in the left bar, then select Share with specific people. 

See the calendars you've created 

1. On your computer, open Google Calendar. 

2. On the left side of the page, under "My calendars," you'll see a list of the calendars you've created. 

3. To show or hide that calendar's events, click the calendar's name. 

4. To remove a calendar from your list, next to the calendar's name, click Options   Hide from list. 

Edit your calendar's name 

1. Open Google Calendar . 

2. On the left side of the page, under My calendars, find your calendar. 

3. Next to your calendar, click Options   Settings and sharing. 

4. In the box at the top, choose a new name. 

Change your calendar’s color 

Open Google Ca Work with Office files 

You can edit, download, and convert Microsoft® Office files in Google Docs, Sheets, and Slides. 

To edit an Office file, you can either: 

• Edit the file using Office Compatibility Mode (OCM) 

• Convert the file to Google Docs, Sheets, or Slides. 

Once you've edited a Google Docs, Sheets, and Slides file, you can then save and export it as an Office file to 

share with others. 

Edit Office files 

1.  calendar. 

2. On the left side of the page, under My calendars, find your calendar. 

3. Next to your calendar, click Options  . 

4. Pick the color for your calendar, or click Add custom color 

GOOGLE DRIVE 

Step 1: Go to drive.google.com 

• Files and folders you upload or sync 

• Google Docs, Sheets, Slides, and Forms you create 

Step 2: Upload or create files 
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You can upload files from your computer or create files in Google Drive. 

Upload & view files 

Work with Office files 

You can edit, download, and convert Microsoft® Office files in Google Docs, Sheets, and Slides. 

To edit an Office file, you can either: 

• Edit the file using Office Compatibility Mode (OCM) 

• Convert the file to Google Docs, Sheets, or Slides. 

Once you've edited a Google Docs, Sheets, and Slides file, you can then save and export it as an Office file to 

share with others. 

Edit Office files 

Computer Android iPhone & iPad 

Edit files using Office Compatibility Mode (OCM) 

To open and edit Office files, you can use Office Compatibility Mode (OCM). With OCM, you can open and edit 

Office files in Drive, the Docs, Sheets, and Slides homescreens & apps, and Gmail. 

Use OCM with Google Docs, Sheets, and Slides 

Download Office files 

To download Office files using OCM: 

1. Open a Chrome browser window. 

2. Open an Office file. 

3. In the top right, click Download. 

Convert an Office file to Docs, Sheets, or Slides 

If you want to work with others on a file in real-time, you can convert an Office file to Google Docs, Sheets, or 

Slides. 

Convert an Office file 

Features not supported 

Save & export files to an Office format 

After converting your Office files to Google Docs, Sheets, or Slides, or using OCM to make edits to your file, you 

can save and export the file back to an Office format and share it with others. 
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To save your Google Doc, Sheet, or Slide back as an Office file: 

1. Open the file. 

2. Click File  Download as. 

3. Choose a file format. 

 

On your computer, you can upload from drive.google.com or your desktop. You can upload files into private or 

shared folders. 

1. On your computer, go to drive.google.com. 

2. At the top left, click New   File Upload. 

3. Choose the file you want to upload. 

Drag files into Google Drive 

1. On your computer, go to drive.google.com. 

2. Open or create a folder. 

3. To upload files and folders, drag them into the Google Drive folder. 

Use Backup & Sync 

1. Install the application on your computer. 

2. On your computer, you'll see a folder called "Google Drive." 

3. Drag files or folders into that folder. They will upload to Drive and you will see them 

on drive.google.com. 

Convert documents into Google formats 

If you want to upload files like Microsoft Word documents, you can change a setting to convert files. 

Note: You can only change Google Drive settings from your computer. 

1. Using a computer, go to drive.google.com/drive/settings. 

2. Next to "Convert Uploads," check the box. 

Upload files with the same name 

If you upload a file with the same name, Google Drive will upload the file as a revision of the file already in 

Google Drive. 

To keep both files: 

1. On your computer, go to drive.google.com. 

2. Upload a file. 
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3. Click Keep as separate file. 

Share files from Google Drive 

You can share the files and folders that you store in Google Drive with anyone. 

When you share from Google Drive, you can control whether people can edit, comment on, or only view the 

file. When you share content from Google Drive, the Google Drive program policies apply. 

Step 1: Find the file you want to share 

Share a single file 

1. On a computer, go to Google Drive, Docs, Sheets, or Slides. 

2. Click the file you want to share. 

3. Click Share or Share 

Step 2: Choose who to share with & how they can use your file 

Share with specific people 

1. Under "People," enter the email address you want to share with.  

• Note: If you share with an email address that isn’t a Google Account, they’ll only be able to view 

the file. 

2. To choose what someone can do with your file, click the Down arrow . 

3. If you don’t want to send an email to people, click Advanced and uncheck the Notify people box. If you 

notify people, each email address you enter will be included in the email. 

4. Click Send. 

QUESTIONS 

Part-A 

1. What is a Google Form? 

2. What are the options available in Title and description in a google form? 

3. What is Multiple Choice Grid in a google form? Explain? 

4. Can Google form responses be stored? If so, how? 

5. What is a Google Drive? What is it used for?  

6. How to share files from Google Drive? 

 

Part-B 

1. How to create a google form? What are the options available? 

2. Create an online Quiz and store the responses obtained from 5 Students. Give stepwise Procedure. 

3. Create an Online Event registration form for a Chess Competition with a sample prefilled form. Give 

stepwise Procedure. 

4.  

a) Create a Calendar 

https://drive.google.com/
https://docs.google.com/
https://sheets.google.com/
https://slides.google.com/
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b) What is a google drive? Explain the steps to upload or create files in a google drive? 
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